tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "alla winter" <alla1.win...@gmail.com>
Subject Fwd: Issue with setting TOMCAT 5.5.28 on AMD64
Date Wed, 14 Nov 2007 19:52:58 GMT
I had run service.bat  it installed TOMCAT as a service( all parameters in
my e-mail bellow), but then  then it fail.  Any help would be very
appreciated:  I found the following errors in the log:

[2007-11-14 13:36:22] [info] Procrun (2.0.3.0) started
[2007-11-14 13:36:22] [info] Service Tomcat5 name Apache Tomcat
[2007-11-14 13:36:22] [info] Service Tomcat5 installed
[2007-11-14 13:36:22] [info] Procrun finished.
[2007-11-14 13:36:22] [info] Procrun (2.0.3.0) started
[2007-11-14 13:36:22] [info] Updating service...
[2007-11-14 13:36:22] [info] Service Tomcat5 updated
[2007-11-14 13:36:22] [info] Update service finished.
[2007-11-14 13:36:22] [info] Procrun finished.
[2007-11-14 13:36:22] [info] Procrun (2.0.3.0) started
[2007-11-14 13:36:22] [info] Updating service...
[2007-11-14 13:36:22] [info] Service Tomcat5 updated
[2007-11-14 13:36:22] [info] Update service finished.
[2007-11-14 13:36:22] [info] Procrun finished.
[2007-11-14 13:37:15] [info] Procrun (2.0.3.0) started
[2007-11-14 13:37:15] [info] Running Service...
[2007-11-14 13:37:15] [info] Starting service...
[2007-11-14 13:37:15] [174  javajni.c] [error] %1 is not a valid Win32
application.
[2007-11-14 13:37:15] [986  prunsrv.c] [error] Failed creating java
C:\jdk1.5.0_13\jre\bin\server\jvm.dll
[2007-11-14 13:37:15] [1260 prunsrv.c] [error] ServiceStart returned 1
[2007-11-14 13:37:15] [info] Run service finished.
[2007-11-14 13:37:15] [info] Procrun finished.
[2007-11-14 13:37:47] [info] Procrun (2.0.3.0) started
[2007-11-14 13:37:47] [info] Running Service...
[2007-11-14 13:37:47] [info] Starting service...
[2007-11-14 13:37:47] [174  javajni.c] [error] %1 is not a valid Win32
application.e.bat

---------- Forwarded message ----------
From: alla winter <alla1.winter@gmail.com>
Date: Nov 14, 2007 1:25 PM
Subject: Issue with setting TOMCAT 5.5.28 on AMD64
To: users@tomcat.apache.org


Hello,
I installed TOMCAT 5.5.25 with APR on  the computer with Intel(R) XEON(R)
Processor E5345 with operating SYstem Server  2003 R2 64 bit
java environment: jdk 1.5.13 64 bit
I am able to start TOMCAT with startup.bat and run the application over http
and https protocols.
However, I can not install tomcat as Windows service using tomcat5.exe
I am getting the following error message:

[2007-11-14 12:52:08] [420  prunsrv.c] [error]
The system cannot find the file specified.
[2007-11-14 12:52:08] [1327 prunsrv.c] [error]
Load configuration failed

I read that I need to have msvcr71.dll - I c hecked, I do not have it in my
win32 directory   I copied it from another 32 bit server (where the same
version of TOMCAT is successfully installed as service) and put it in my
CATALINA_HOME\bin directory, but it didn't make any difference.  May be it
was wrong to do, but where can I get this 64 bit dll, and I am not even sure
that this is because I do not have msvcr71.dll

I would appreciate any help in this matter
thanks

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message