tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wilhelmsen Tor Iver" <>
Subject 6.0.14, Defaultservlet and 400 errors
Date Thu, 15 Nov 2007 09:57:01 GMT
We are running multiple Catalina homes from one install, and ordinary
webapps deployed under them work fine. However, whenever static content
(in our case PDFs) is requested, Tomcat responds with

HTTP 1/1 400 No Host matches server <hostname>

- Running under Linux (Red Hat Enterprise) on JDK 1.5.0_03 as the same
user that owns the directory tree; uploading files to the folders under
the appBase works fine.
- There is only one Host defined in each server.xml ("localhost"), but
the server name is defined as an <Alias>; other Tomcat (5.5.x)
installations (on Windows) where the PDF download worked well did not
show this problem, and had not even any <Alias> entries for the machine
- appBase for the Host is declared relative. Should this perhaps be
absolute? But other apps are easily found...
- We also tried adding directories for the aliases under conf/Catalina
with no more success
- One of the Tomcats sits behind an Apache using the AJP connector, but
the only effect is that the 400-errors are forwarded when the request
matches one of the forwarded apps.

I googled a bit but it seemed that most other occurences of this problem
also affected other webapps under the appBase, while in our case these
run fine, including JSP compilation. It's just the static content
delivered by DefaultServlet that gives the error response...

Anyone have any ideas? Can it be caused by a change from 5.5 to 6.0
which would be remedied if we changed the Linux installation to 5.5.x?

Med vennlig hilsen

Senior systemutvikler
Arrive AS
T (+47) 48 16 06 18

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message