tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Gainty" <>
Subject Re: Tomcat connections not closing.
Date Thu, 01 Nov 2007 14:23:30 GMT

I would strongly suggest use of Version Control for archiving your
configuration files
server.xml/web.xml and context.xml, catalina.policy,,, tomcat-users.xml
In the case of axis you want to archive
In the case of struts you want to archive struts-default.xml
In this way you determine at least the version of the configurations (and
hopefully date-time as well as Login)


----- Original Message -----
From: "Roark, Mike" <>
To: "Tomcat Users List" <>; <>
Sent: Wednesday, October 31, 2007 11:04 AM
Subject: RE: Tomcat connections not closing.

Well, yes and no.

Yes, the problem has abated, and possibly been eliminated. However, we
have no idea what change fixed it. We changed nothing in tomcat, but
some changes were made at the network and in the application itself
(regularly scheduled updates). None of the changes were intended to fix
the problem, but it went away anyway.

I don't like it, since I assume the problem could come back at any time.
I still think Tomcat should be able to protect itself from this kind of
behavior, but I haven't had good luck yet with the suggested parameter
tweaks. At this point I'm not continuing to look into it, but just
keeping watch over it...


-----Original Message-----
From: Ralph Goers []
Sent: Saturday, October 27, 2007 10:48 AM
To: Tomcat Users List
Subject: Re: Tomcat connections not closing.


Have you been able to make any progress with this? I'm very interested
in the outcome as we experience the same problem.


Roark, Mike wrote:
> Filip,
> Thanks for the help.
> You were right about the default for disableUploadTimeout. I must have
> been looking at 5.0 docs before, it looks like the default changed
> between 5.0 and 5.5.
> So I have now specified all three settings as you have them, and have
> had no effect. It seems like the socket remains open for as long as I
> feel like waiting. I have a perl script that will make a request and
> then not read the response (just sleeps), and another that will open a
> socket but not even write a GET line. Same result in both cases.
> I said that I could see the reads timeout, but now I'm not even seeing
> that. I would expect if I don't send a GET that the connectionTimeout
> would definitely apply.
> -Mike

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message