tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: Issue finding Worker using mod_jk ...
Date Thu, 08 Nov 2007 21:38:03 GMT
Hi Kim,

as Filip indicated it would be helpful, to also see your other JK
configuration options, i.e. the JK Apache directives you used.

Fron the log output I guess, that your JK version is something around
1.2.6. We are now at 1.2.25, so I would suggest to do an update before
into digging into the problem (I'm not saying your problem comes from
the old version).

Your log output looks, like the JkMount worked, but the
workers.properties entry didn't work. Are you sure, that you configured
the workers.properties correctly in your httpd.conf?

Newer versions of mod_jk log quite a lot of details in debug level
during startup and configuration parsing, so it would be easier for us
to find out the reason for your problem.

Regards,

Rainer

Kim Albee schrieb:
> We are having an issue when setting up integration between Apache 2.0.52 and
> Tomcat 6.0.14...
> 
> Here are the mod_jk.log entries:
> 
> [Wed Nov 07 14:31:25 2007]  [jk_uri_worker_map.c (445)]: Into
> jk_uri_worker_map_t::map_uri_to_worker
> [Wed Nov 07 14:31:25 2007]  [jk_uri_worker_map.c (459)]: Attempting to map
> URI '/'
> [Wed Nov 07 14:31:25 2007]  [jk_uri_worker_map.c (473)]:
> jk_uri_worker_map_t::map_uri_to_worker, Found an exact match ein1 -> /
> [Wed Nov 07 14:31:25 2007]  [mod_jk.c (1689)]: Into handler r->proxyreq=0
> r->handler=jakarta-servlet r->notes=158639048 worker=ein1
> [Wed Nov 07 14:31:25 2007]  [jk_worker.c (90)]: Into wc_get_worker_for_name
> ein1
> [Wed Nov 07 14:31:25 2007]  [jk_worker.c (94)]: wc_get_worker_for_name, done
> did not find a worker
> 
> The workers.properties file looks like this:
> 
> workers.tomcat_home=/usr/local/tomcat6
> workers.java_home=$JAVA_HOME
> ps=/
> worker.list=ein1
> 
> 
> worker.ein1.port=8109
> worker.ein1.host=localhost
> worker.ein1.type=ajp13
> worker.ein1.info=Ajp13 forwarding
> worker.ein1.debug=2
> worker.ein1.tomcatId=ein1
> 
> We have the jvmRoute set in the Engine parameter for the server.xml in
> tomcat as well...
> 
> Any suggestions on how to get this working?
> 
> thanks,
> Kim :-)
> 

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message