tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael <sg...@gmx.net>
Subject Re: Tomcat 6.0.14 and UTF-8 POST form problem
Date Thu, 08 Nov 2007 09:28:03 GMT
Yigal Lazarev wrote:
> Hi,
> 
> I'm deploying a JSF WAR onto Tomcat 6.0.14 under Windows 2003 with JVM
> version 1.6.0_03-b05, and using MySQL db.
> When I submit a form using POST method, and in the server side take the
> fields and send them as an email using JavaMail- i lose the UTF-8 encoded
> characters sent in the form.
> 
> I suspect it's something with the Tomcat configuration because it does not
> happen when I deploy to Sun Application Server 8.2
> And another thing, UTF-8 characters hardcoded in the sending email method
> are sent just fine.

Shalom Yigal,

all your efforts are useless. Just do the following thing and you'll be 
happy:

open up the server.xml

search for the Connector node which works for HTTP and add the attribute 
URIEncoding="UTF-8"
restart tomcat and go on using:

String string = request.getParamter("name");

that's it. Works perfectly here.

Some reference for you: 
http://confluence.atlassian.com/display/DOC/Configuring+Tomcat's+URI+encoding

Lehitraot,

Michael
-- 
<NO> OOXML - Say NO To Microsoft Office broken standard
http://www.noooxml.org

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message