tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rocco Scappatura" <Rocco.Scappat...@sttspa.it>
Subject Re: Problems with a web application running a PHP script
Date Wed, 07 Nov 2007 22:19:10 GMT

>> Thanks for you hints. I will disinstall all JDK/JRE versions from my PC.
>> I'm dowloading JDK 6 Update 3 and I will install it.
>
> No problem, you got me curious about scripting...
> I Tested with this
> ======================================
>     protected void processRequest(HttpServletRequest request,
> HttpServletResponse response)
>             throws ServletException, IOException {
>         response.setContentType("text/html;charset=UTF-8");
>         PrintWriter out = response.getWriter();
>
>
>         out.println("<html>");
>         out.println("<head>");
>         out.println("<title>Servlet NewServlet</title>");
>         out.println("</head>");
>         out.println("<body>");
>         out.println();
>         out.println("<p>Stand Back... Script running</p>");
>
>       ScriptEngineManager scriptMgr = new ScriptEngineManager();
>       ScriptEngine jsEngine = scriptMgr.getEngineByName("JavaScript");
>       try {
>         jsEngine.eval("var meJavaScript = 'Me-Java Script!';");
>         out.println("<p>" + jsEngine.get("meJavaScript") + "</p>");
>       }
>       catch (ScriptException ex) {
>         out.println("<p>Oh Damn! Script Crashed " + ex.getMessage() +
> "</p>");
>         ex.printStackTrace();
>       }
>
>         out.println("</body>");
>         out.println("</html>");
>         out.close();
>     }
>

Hello Chunk,

I have a big news.

After I have installed:

java version "1.6.0_03"
Java(TM) SE Runtime Environment (build 1.6.0_03-b05)
Java HotSpot(TM) Client VM (build 1.6.0_03-b05, mixed mode, sharing)

and set this new platform for my web appl, I get that the web app does not
works under NB bundled Tomcat too (other than unnder Tomcat 5.5.25
installed by hand).

At this point, I think that is almost clear that scripting (JSR223Script
class) working depends on JDK version (I can't figure out if there is a
particular class releases with JDK that is guilty of this
incompatibility).

If someone has a more technical explanationis welcomed! :-)

rocsca



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message