tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "albert quinn" <albertber...@gmail.com>
Subject Re: [Tomcat 5.5.17] Strange Problem With Batabase Connection Pool
Date Thu, 29 Nov 2007 21:26:24 GMT
  It could be. I'm really lost, and have no idea about what is happening.

  I forgot to tell that, when I call the web service after about an
hour of inactivity and it waits forever at the 3th line, if i call the
web service again, it works nice and it keeps on working nice (except
if I wait about an hour again). So, it could be what you say.

  Any URL where I can learn about the DBCP configuration and how to
set testOnBorroy to true?.

  MANY thanks for your help with this strange behaviour!!.



2007/11/29, Mark Thomas <markt@apache.org>:
> albert quinn wrote:
> >   The lines 1 and 2 are executed, but the 4th line is never reached.
> > Any idea of what could be happening here or how could I do to discover
> > what's happening? does it seems to be a bug on my code or a setup
> > problem?
>
> Could you database connection be timing out due to inactivity? It is worth
> adding a validation query to your DBCP configuration and setting
> testOnBorrow to true.
>
> Mark
>
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message