tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew123 <Intel...@ukr.net>
Subject problem with tomcat 6
Date Fri, 16 Nov 2007 12:57:13 GMT

When I start tomcat with my application, I get an exception:
java.lang.NoClassDefFoundError: javax/servlet/http/HttpServlet
	java.lang.ClassLoader.defineClass1(Native Method)
	java.lang.ClassLoader.defineClass(Unknown Source)
	java.security.SecureClassLoader.defineClass(Unknown Source)
	java.net.URLClassLoader.defineClass(Unknown Source)
	java.net.URLClassLoader.access$000(Unknown Source)
	java.net.URLClassLoader$1.run(Unknown Source)
	java.security.AccessController.doPrivileged(Native Method)
	java.net.URLClassLoader.findClass(Unknown Source)
	java.lang.ClassLoader.loadClass(Unknown Source)
	sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	java.lang.ClassLoader.loadClass(Unknown Source)
	java.lang.ClassLoader.loadClassInternal(Unknown Source)
	java.lang.ClassLoader.defineClass1(Native Method)
	java.lang.ClassLoader.defineClass(Unknown Source)
	java.security.SecureClassLoader.defineClass(Unknown Source)
	java.net.URLClassLoader.defineClass(Unknown Source)
	java.net.URLClassLoader.access$000(Unknown Source)
	java.net.URLClassLoader$1.run(Unknown Source)
	java.security.AccessController.doPrivileged(Native Method)
	java.net.URLClassLoader.findClass(Unknown Source)
	java.lang.ClassLoader.loadClass(Unknown Source)
	sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	java.lang.ClassLoader.loadClass(Unknown Source)

org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1273)

org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1204)

org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:263)
	org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)

org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:584)
	org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
	java.lang.Thread.run(Unknown Source)
but there is sevlet-api.jar in  <CATALINA_HOME>/lib directory. I use tomcat
6.0.14, Red Hat Enterprise Linux Server release 5. 

Any ideas?
-- 
View this message in context: http://www.nabble.com/problem-with-tomcat-6-tf4821029.html#a13792543
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message