tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karim Zaki <Karim.Z...@itworx.com>
Subject Passing JVM parameters through the GUI in Tomcat 5.0.28
Date Mon, 26 Nov 2007 09:30:59 GMT
Hi all,

I'm trying to pass some parameters to Tomcat 5.0.28. The product I'm installing (Vignette)
explains how to do this when you run Tomcat using scripts:

set CATALINA_OPTS=-Xmx512M -Dcom.vignette.installDir="<vgn-install-dir>" -Dcom.vignette.workingDir="<vgn-working-dir>"

This works perfectly.

However, when I run Tomcat as a service, things start to break. It's my understanding that
I can pass these parameters to Tomcat by putting them in the "Java Options" box in the "Java"
tab of the Tomcat monitoring tool (while Xmx can be put in the appropriate text box at the
bottom). However, when I do this the parameters do not get set and the application doesn't
work. It clearly says that com.vignette.workingDir has not been properly set.

This is what my Java Options box looks like now:

-Dcatalina.base=C:\Tomcat
-Dcatalina.home=C:\Tomcat
-Djava.endorsed.dirs=C:\Tomcat\common\endorsed
-Djava.io.tmpdir=C:\Tomcat\temp
-Dcom.vignette.installDir=<vgn-install-dir>
-Dcom.vignette.workingDir=<vgn-working-dir>

I've also tried modifying the service creation script. This seems only to have added the parameters
to the monitoring GUI.

Any ideas how I can make this work?

Thanks,
Karim



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message