tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johnny Kewl" <j...@kewlstuff.co.za>
Subject Re: WindowsXP, jre1.6.0_03, Tomcat 5.5 - Tomcat Service won't start
Date Thu, 08 Nov 2007 07:03:46 GMT

---------------------------------------------------------------------------
HARBOR: http://coolharbor.100free.com/index.htm
Now Tomcat is also a cool pojo application server
---------------------------------------------------------------------------

When I change my JRE to a location one that is wrong, I get the same error.
Shouldnt this....
C:\Program Files\Java\jre1.6.0_03\bin\client\jvm.dll
be this
C:\Program Files\Java\jre1.6.0_03\jre\bin\server\jvm.dll

Then another tip... I never ever install Java stuff in Program Files
Why MS made a location with a space in the path... is stupid.

>From the tomcat bin, start tomcat5w.exe
Go to the java tab, fix that.... you referencing the "client"

Just to make sure a space in the path is also not an issue
put quotes around tha path... browsing will probably do that.

"C:\Program Files\Java\jre1.6.0_03\jre\bin\server\jvm.dll"

Have Fun...


----- Original Message ----- 
From: "Ferindo Middleton" <ferindo.middleton@gmail.com>
To: <users@tomcat.apache.org>
Sent: Thursday, November 08, 2007 6:20 AM
Subject: WindowsXP, jre1.6.0_03, Tomcat 5.5 - Tomcat Service won't start


> I've installed the Java Software (jre1.6.0_03) and Tomcat 5.5 on my 
> Windows
> XP computer. When I try to start the service I get an error message that
> Windows was unable to start the service. Looking at the log file (located 
> at
> C:\Program Files\Apache Software Foundation\Tomcat
> 5.5\logs\jakarta_service_20071107.log) I can't figure out why it won't
> start. The log file contains the following:
>
> [2007-11-07 22:53:00] [986  prunsrv.c] [error] Failed creating java
> C:\Program Files\Java\jre1.6.0_03\bin\client\jvm.dll
> [2007-11-07 22:53:00] [1260 prunsrv.c] [error] ServiceStart returned 1
> [2007-11-07 22:53:00] [info] Run service finished.
> [2007-11-07 22:53:00] [info] Procrun finished.
> [2007-11-07 22:53:49] [info] Procrun ( 2.0.3.0) started
> [2007-11-07 22:53:49] [info] Running Service...
> [2007-11-07 22:53:49] [info] Starting service...
> [2007-11-07 22:53:49] [174  javajni.c] [error] The specified module could
> not be found.
> [2007-11-07 22:53:49] [986  prunsrv.c] [error] Failed creating java
> C:\Program Files\Java\jre1.6.0_03\bin\client\jvm.dll
> [2007-11-07 22:53:49] [1260 prunsrv.c] [error] ServiceStart returned 1
> [2007-11-07 22:53:49] [info] Run service finished.
> [2007-11-07 22:53:49] [info] Procrun finished.
>
> Any ideas what's wrong?
> -- 
> Ferindo
> 


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message