tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Fresh install of Tomcat - getting frustrated with the JSP noworking
Date Wed, 03 Oct 2007 15:23:30 GMT
> From: Marty Hall [mailto:hall@coreservlets.com] 
> Subject: RE: Fresh install of Tomcat - getting frustrated 
> with the JSP noworking
> 
> If you compile directly (from TextPad or UltraEdit or the 
> command line), then you need to either set the CLASSPATH
> variable or pass -classpath on the command line or put the 
> JARs in the ext folder (this is in the development environment, not 
> the server environment).

That is indeed correct.  However, the links within the tutorial indicate
that CLASSPATH should be set for the Tomcat server execution, not just
servlet compilation.  Including those jars in the CLASSPATH during
Tomcat execution causes multiple copies of the classes to be loaded
under different classloaders, resulting in no end of grief with CNFE
problems.  (Also, the given location of the jars is incorrect for Tomcat
6.)

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
MATERIAL and is thus for use only by the intended recipient. If you
received this in error, please contact the sender and delete the e-mail
and its attachments from all computers.

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message