tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Rodríguez Anaya <arodrig...@dia.uned.es>
Subject Problem: stasrtup Tomcat in Mac os X 10.4.2
Date Mon, 15 Oct 2007 16:46:30 GMT
Hi!

I have problems to start up Tomcat 5.5 and 6.0. I have downloaded  
core binary distributions and I have followed the instructions.

As a root I have unpacked and moved it to /user/local directory. I  
have secified the CATALINA_HOME and JAVA_HOME variables. I have set  
execute permisions to all *.sh files in $CATALINA_HOME/bin/ (chmod ug 
+x *.sh). I have tried to start up Tomcat but it does not work. First  
the message is:
Using CATALINA_BASE:   /usr/local/tomcat-5
Using CATALINA_HOME:   /usr/local/tomcat-5
Using CATALINA_TMPDIR: /usr/local/tomcat-5/temp
Using JRE_HOME:       /usr/bin/java

This is normal, I think, but Tomcat does not work. The catalina.log  
file shows this error message:
/usr/local/tomcat-5/bin/catalina.sh: line 273: /usr/bin/java/bin/ 
java: Not a directory

The catalina.sh file line number 273 is:
  "$_RUNJAVA" $JAVA_OPTS $CATALINA_OPTS \

I understand the value of JAVA_OPTS or CATALINA_OPTS is "/usr/bin/ 
java" and "/bin/java". I think something wrong happends, because I  
had not set either JAVA_OPTS or CATALINA_OPTS. I have tried to set  
these variables with the value "-server -Xmx400m", but the situation  
has not changed. The error message in catalina.log is the same.

I do not understand what happen. Is it possible the problem is for  
the operation system? My os is Mac os X 10.4.2. Does someone know how  
I can correct the problem?

Thanks in advance,

Antonio.
  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message