tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pid...@pidster.com>
Subject Re: placing jars in /server/lib - can cause oome?
Date Wed, 10 Oct 2007 22:05:32 GMT
Christopher Schultz wrote:
> A C,
> 
> A C wrote:
>> We've been experiencing horrendous OOMEs recently after deploying 40 clones
>> of a vendor's .war file which encompasses their application/portal.  The
>> context is about 100MB
> 
> Lesee... 100 MB times 40 instances .. mm... carry the 7 ... hey, that's
> 4GB! Where have I heard that number before... hmm.. something about ...
> right! The maximum process memory on a 32-bit OS!

lol



A C, I have to say this: the clue is in the question...

I'll summarise; it works OK when when you deploy one copy of a 100Mb
app, but when you deploy FORTY it gets a bit messy and you run out of
memory.

How is it that you're not thinking about more servers at this point?

(I'd be waving a nice diagram at the accountants and saying 'shiny new
boxes please')


p






---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org





---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message