tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Samik Basu" <samik.b...@gmail.com>
Subject Tomcat 5x SSI
Date Fri, 26 Oct 2007 15:51:03 GMT
  I am running Apache-Tomcat 5.5.25 - plugged into Eclipse. I have updated
the web.xml and renamed the renametojar files  in server/lib/ to allow cgi
and ssi.  A tomcat project named "TomcatProject" is created in Eclipse and
the server.xml is updated with the context information as follows:

      <Context path="/Tomcat"
                docBase=My location of TomcatProject
                debug="0"
                reloadable="true">
       </Context>

In my TomcatProject/WEB-INF I have created a cgi directory inside which all
my cgi files exist. Everything is working okay - for example I can see
correct results for
http://localhost:8080/Tomcat/cgi-bin/test.cgi
and
http://localhost:8080/Tomcat/test.shtml

However, there is one small problem. When I try to execute a cgi program
from shtml file using the following directive:
<!-#include virtual="/cgi-bin/test.cgi"-->
it says that the context for /cgi-bin/test.cgi is not found.
If I use
<!--#include virtual="/Tomcat/cgi-bin/test.cgi"-->
It rightly says that the file is not found.
I have tried out (I think) all possible ways to execute the program - using
exec cgi=, exec virtual=,

Interestingly, when I do <!--#include virtual="/Tomcat/test.jsp"--> it works
fine i.e. I can include any other types of files.

Can anyone provide some insights. Thanks.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message