tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Li Ye Chen <l...@cornell.edu>
Subject Perl Permissions on Tomcat
Date Mon, 08 Oct 2007 15:41:05 GMT
Hi,
   I'm trying to run a Perl script on Tomcat 5.5.8 -- I've managed to successfully run read-only
Perl script, but the script I'm trying to run connects to the database and needs to write
to the local hard drive. Whenever I try to execute the script, it creates a Perl.exe thread
on my Windows server and just never return the HTML code (so the browser keeps loading) --
it seems there is a permission problem. I've tried executing the script on plain old DOS and
it works just fine (returns the right HTML code with database information). I've also searched
the mailing archives, and tried changing the catalina.policy file by adding the following
line:

// Give all permission to servlets-cgi.jar
grant codeBase "file:${catalina.home}/server/lib/servlets-cgi.jar" {
        permission java.security.AllPermission;
};

but it doesn't work. Any idea how I can give Perl.exe read/write permission as executed through
Tomcat 5.5.8? Thanks in advance!


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message