tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Class loading issue
Date Fri, 26 Oct 2007 17:45:42 GMT
> From: Tony Fountain [mailto:tfountain@benefitconcepts.com] 
> Subject: RE: Class loading issue
> 
> However, that does not clarify for me why it only 
> happens when I attempt to set the <load-on-startup> 
> element in the webapps web.xml file

Don't have a real answer for that, at least not yet (but see below for
speculation).  Might need a classloader trace to figure that out, and
it's probably not worth the trouble.

> As far as the JAVA_OPTS go, I do not see where I 
> have this set at all.

That's fine; JAVA_OPTS isn't used for the Windows service.

> -Djava.endorsed.dirs=C:\Apache\Tomcat\common\endorsed

Is there anything in the above directory?  If so, it may be involved.

The parser class name can also be specified in a .jar via a service
provider configuration file:
META-INF/services/javax.xml.parsers.DocumentBuilderFactory

If such a jar file is seen before or during the call to
DocumentBuilderFactory.newInstance(), it would appear to apply globally.
Not sure what happens if the jar file is encountered after the
newInstance() call, or if multiple jar files have conflicting settings.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
MATERIAL and is thus for use only by the intended recipient. If you
received this in error, please contact the sender and delete the e-mail
and its attachments from all computers.

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message