tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From robert rowntree <rowntree...@yahoo.com>
Subject linux FC5 and tomcat autodeploy
Date Thu, 25 Oct 2007 19:01:32 GMT
expected behavior using default <Engine config in "server.xml" is that WAR files will expand
and deploy when they are placed in ./tomcatRoot/webapps.

expected behavior using "manager' app and http requests covered in docs at http://tomcat.apache.org/tomcat-5.5-doc/manager-howto.html
is that when you authenticate to manager application and Post a url asking to undeploy a /Context
that the root directory of that context will be deleted and all the files will be deleted.


what we have observed is that the autodeploy does not expand the WAR all the time. 
what we have observed in undeploy is that the message appears "context undeployed" but all
the files under that context actually remain. 
my FAQ is that when we made the server.xml change to the following tag, the problem seems
to have gone away. The docs say that the attribute we added ______ is defaulted to "10 seconds".
However i wonder.....

  <!--  <Engine name="Catalina" defaultHost="localhost">  -->
    <Engine name="Catalina" defaultHost="localhost" backgroundProcessorDelay="10">


when we added the "backgroundProcessorDelay" to our server.xml on FedoraCore5, the autodeploy
problems described above in this post seem to have disappeared.

Has anyone noticed similar behavior on linux?



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message