tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From javaxmlsoapdev <vika...@yahoo.com>
Subject NIO connector in Tomcat 6.0.14
Date Thu, 25 Oct 2007 16:04:46 GMT

I am trying to use NIO connector for getting comet chat example work. 

Here is what I have in server.xml. I commented out original connector on
8080 (as you can see below) and added NIO on port 8080. 
 <!--Connector port="8080" protocol="HTTP/1.1" 
               connectionTimeout="20000" 
               redirectPort="8443" -->
    <Connector port="8080"
protocol="org.apache.coyote.http11.Http11NioProtocol" maxThreads="150"
connectionTimeout="20000" redirectPort="8443" />	

I don't above is setup correctly due to two things
1)It takes forever (may be until specified timeout period) to respond and
request comes back doing nothing
2)Comet chat example doesn't work. No errors or anything but it simply
doesn't push chat messages to client browsers, I have two browsers open
running same chat application.

Am I not setting up connector properly? Is there any other config required?
how to get this comet chat example working. Please note that I searched the
forum already but still confused on NIO connector entry in server.xml.

Any ideas?

Thanks,
-- 
View this message in context: http://www.nabble.com/NIO-connector-in-Tomcat-6.0.14-tf4691648.html#a13409349
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message