tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeffrey Nguyen \(jeffrngu\)" <jeffr...@cisco.com>
Subject RE: java.net.MalformedURLException: no protocol: Files/thirdparty/TOMCAT/common/classes/
Date Wed, 26 Sep 2007 21:34:59 GMT

Hi Chris,

I can "cd" to all 4 paths w/o any problem (see below).  I also verified
that TransactionRef class is part of
CATALINA_HOME/common/lib/naming-factory.jar

C:\>echo %CATALINA_HOME%
C:\Program Files\thirdparty\TOMCAT
C:\>cd %CATALINA_HOME%/common/classes
C:\Program Files\thirdparty\TOMCAT\common\classes>cd\
C:\>cd %CATALINA_HOME%/common/i18n
C:\Program Files\thirdparty\TOMCAT\common\i18n>cd
%CATALINA_HOME%/common/endorsed
C:\Program Files\thirdparty\TOMCAT\common\endorsed>cd
%CATALINA_HOME%/common/lib/
C:\Program Files\thirdparty\TOMCAT\common\lib>

At this point, I'm considering reinstalling Tomcat in a different
directory as the last resort because it's involved a lot of work. I am
looking for a workaround.

- Jeffrey Nguyen

-----Original Message-----
From: Christopher Schultz [mailto:chris@christopherschultz.net] 
Sent: Wednesday, September 26, 2007 12:27 PM
To: Tomcat Users List
Subject: Re: java.net.MalformedURLException: no protocol:
Files/thirdparty/TOMCAT/common/classes/

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jeffrey,

Jeffrey Nguyen (jeffrngu) wrote:
> I had actually tried to define the value for catalina.home explicitely

> in catalina.properties file, but I still can't get this working.

Not sure if catalina.home can actually be specified here. You may have
to specify it externally.

> common.loader=${catalina.home}/common/classes,${catalina.home}/common/
> i1 
> 8n/*.jar,${catalina.home}/common/endorsed/*.jar,${catalina.home}/commo
> n/
> lib/*.jar
> 
> With this definition, I got the following stacktrace:
> 
> 2007-09-26 13:53:13,000 ERROR [Thread-6] 
> rmidispatcher.TCTTaskDispatcherImpl - java.rmi.ServerException:
> RemoteException occurred in server thread; nested exception is: 
> 	java.rmi.UnmarshalException: error unmarshalling arguments;
nested 
> exception is:
> 	java.net.MalformedURLException: no protocol:
> Files/thirdparty/TOMCAT/common/classes/

Yes. It's obvious that the path still contains the space, and that the
loader is considering it to be a path delimiter instead of part of the
path itself.

> If I replace "${catalina.home}" with "C:/Program~1/thirdparty/TOMCAT"
> for the first path, I'll get MalformedURLException exception again for

> the second path. If I made the same change for the first 2 paths, I'll

> get the same exception complaining about the third path.  If I do this

> for the first 3 paths, the same exception points to the last path.
> 
> When I made the same change for all 4 paths, Tomcat failed to start. I

> got the following error in catalina.* log:
> 
> Sep 25, 2007 9:59:23 AM org.apache.tomcat.util.digester.Digester
> startElement
> SEVERE: Begin event threw error
> java.lang.NoClassDefFoundError: org/apache/naming/TransactionRef

There are two possibilities:

1. Your path is still not correct (likely) 2. Your Tomcat install must
be broken. This class should be in
   CATALINA_HOME/common/lib/naming-factory.jar

Did you check to see that your 8.3 representation of the path is
correct? Try copy-and-pasting that path up there into a "cd" command and
see if windows will put you in the proper directory.

> One more thing: I don't see any of the above exceptions if I don't 
> deploy my servlet that uses RMI. Other servlets that are not using RMI

> seem to work fine. I'm not sure if this issue is triggered when RMI is

> used within Tomcat and when Tomcat is installed under a directory with

> spaces.  The postings I found mentioned the use of RMI.

I assume you need RMI or you wouldn't be asking.

- -chris

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFG+rKQ9CaO5/Lv0PARAt2UAJ0SWFILHZC8VBDoet2UExo6ow+2LwCgvBFT
IZXJsdh+euO/tLKIVgaS7UA=
=BONg
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org To unsubscribe,
e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message