tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Gainty" <mgai...@hotmail.com>
Subject Re: [Fwd: Can&#39;t run jsp pages on tomcat 6.0.10]
Date Wed, 20 Sep 2000 18:54:12 GMT
Hi Sam
your TC 6.0.10 copy is old
here is the source from the lastest 6.0.14 TC distro

package org.apache.jasper;
/**
 * Some constants and other global data that are used by the compiler and 
the runtime.
 *
 * @author Anil K. Vijendran
 * @author Harish Prabandham
 * @author Shawn Bayern
 * @author Mark Roth
 */
public class Constants {
    public static final boolean IS_SECURITY_ENABLED = 
(System.getSecurityManager() != null);

....
}

Martin--
----- Original Message ----- 
From: <samk@twinix.com>
To: <users@tomcat.apache.org>
Sent: Thursday, September 20, 2007 11:09 AM
Subject: Re: [Fwd: Can&#39;t run jsp pages on tomcat 6.0.10]


See Thread at: http://www.techienuggets.com/Detail?tx=7258 Posted on behalf 
of a User

Did anyone end up with a solution or fix for this issue?  I have encountered 
this problem as well.  The one thing I can add is that under http the jsp 
pages compile and run, however under https, that's where I get the error.

In Response To:

Nobody says nothing so i admit it it's something new as i feared. And
probably nobody is using tomcat 6 (wise people).

Well i removed every .jar from my lib for testing it out. And reduced my
web.xml for minimal (welcome file list stuff).

The error HTTP 500 is the same but it presents now a "superficial" part
that it did not appear before.

I am running on a CentOS 4 with Tomcat 6.0.10 and jdk 6.

Am i the only one who thinks the migration between tomcat versions is
too much of a headache? My case before i had a logging classes error in
a tomcat5.5 that it didn't appear on tomcat 5.0 and the only way to go
through with migration it was to downgrade hibernate 3 to hibernate 2,
don't ask me why... Anyway if anyone can helpme on this i would
appreciate it very much.


*exception*

javax.servlet.ServletException: Servlet.init() para servlet jsp lanzó 
excepción
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:216)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:634)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:445)
java.lang.Thread.run(Thread.java:619)

*root cause*

java.lang.NoSuchFieldError: IS_SECURITY_ENABLED
org.apache.jasper.compiler.JspRuntimeContext.<init>(JspRuntimeContext.java:136)
org.apache.jasper.servlet.JspServlet.init(JspServlet.java:101)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:216)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:634)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:445)
java.lang.Thread.run(Thread.java:619)

Each



-------- Mensaje original --------

For any of my jsp pages i get:

java.lang.NoSuchFieldError: IS_SECURITY_ENABLED
org.apache.jasper.compiler.JspRuntimeContext.<init>(JspRuntimeContext.java:136)
org.apache.jasper.servlet.JspServlet.init(JspServlet.java:101)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:216)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:634)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:445)
java.lang.Thread.run(Thread.java:619)

My html pages i get without any problem. And the examples work fine. The
same for another weapp using only zk. But for the old scripting jsp
pages nothing and they worked under tomcat 5.5. Always this error even
if i try with a empty jsp page. I am trying to solve this in the dark as
i can't find any related stuff on this problem.






---------------------------------------------------------------------
To start a new topic, e-mail: noway@spam.com
To unsubscribe, e-mail: users-noway@spam.com
For additional commands, e-mail: users-noway@spam.com





-- 



*Rui Monteiro - 616976483 *

*noway@spam.com* <mailto:noway@spam.com>



*Villanueva de la Serena
Pol. Ind. Cagancha, 9
06700 VILLANUEVA DE LA SERENA (Badajoz)
Telf: 924 840962 y Fax: 924 842261 *
noway@spam.com <mailto:noway@spam.com>



*Mérida
Avda. de la Juan Carlos I, 11
06800 MERIDA (Badajoz)
Telf: 924 318405 y Fax: 924 387352*
noway@spam.com <mailto:noway@spam.com>



*Cáceres
San Vicente de Paúl, esquina a Federico Ballell
10001 CACERES
Telf: 927 246456 y Fax: 927 210986*
noway@spam.com <mailto:noway@spam.com>



---------------------------------------------------------------------
To start a new topic, e-mail: noway@spam.com
To unsubscribe, e-mail: users-noway@spam.com
For additional commands, e-mail: users-noway@spam.com




---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message