tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Gainty" <mgai...@hotmail.com>
Subject Re: AJP Flush Packet causing text/plain output
Date Mon, 25 Sep 2000 16:25:23 GMT
On a related note
Has there been any jk connector releases for Apache HTTP 2.2?

Thanks
M--
----- Original Message ----- 
From: "Mladen Turk" <mladen.turk@gmail.com>
To: "Tomcat Users List" <users@tomcat.apache.org>
Sent: Tuesday, September 25, 2007 11:04 AM
Subject: Re: AJP Flush Packet causing text/plain output


> Jim Jagielski wrote:
> >>
> >> Thanks for the patch. I'll check and likely commit. The core problem 
> >> maybe is inside the Tomcat AJP connector (shouldn't send flush 
> >> packets before sending headers) or in the webapp (which might trigger 
> >> flushes to early), but it will be definitely good to be tolerant on 
> >> the JK side.
> >>
> >
> > +1... I'll look at the mod_proxy_ajp side.
> >
> Right, the problem is in the webapp probably. The first flush shouldn't 
> occur before initial packet is send.
> However the explicit flushes (send_body with size 0) are very important.
> Think the patch is safe, although not tested.
> 
> Regards,
> Mladen
> 
> 
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message