tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ghodmode <ghodm...@ghodmode.com>
Subject Re: NoClassDefFoundError, Tomcat isn't seeing JARs in webapps/<appname>/lib?
Date Tue, 04 Sep 2007 07:21:34 GMT
On 9/4/07, David Delbecq <delbd+jakarta@oma.be> wrote:
>
> J2EE specs says librairies of a webapp must be in /WEB-INF/lib  (that's
> for the part about subjet line where you use /lib)


Thank you David.  That was a typo.  I am actually using WEB-INF/lib.

Now, for you mail content you seem to be indeed using WEB-INF/lib, and
> it seems to be the 3 libs required by wicket example. I suggest you
> investigate the possibility of having downloaded a broken jar. Maybe,
> try switching away from a beta version....


I've double-checked the JAR file and it's okay, but I re-downloaded it
anyway and I still get the same results.  The Wicket download page says that
the latest beta is stable and suggests using it for new projects.  But I
tried version 1.2.6 anyway and I have the same results :(

I have become convinced that this is a Tomcat problem.  Just to be thorough,
though, I'm going to try with an earlier version of Java.  Wicket's site
states that it requires 1.4.  I think that it means 1.4 and up, but I'm
using 1.6.  So, I'll give it a try with 1.5, then with 1.4.

Thank you,
    Vince

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message