tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <>
Subject Re: Tomcat Connector: Attempting to map URI '/examples/index.html' from 0 maps
Date Sat, 01 Sep 2007 11:15:36 GMT
Evert Hoff wrote:
> Hi Rainer,
>> Looks like you've got more than one virtual host in the httpd 
>> configuration. JkMounts are not inherited between virtual hosts. 
>> Although there is the directive JkMountCopy to inherit 
>> JkMount between vhosts, I would expect that not to help in 
>> your situation (localshot:80 vs. So either
>> - define the same JkMounts in the other vhost
> I don't know how to do this. I've tried putting the IP address of the server
> in the conf/auto/mod_jk.conf, but this hasn't made a difference. 
> The server's domain is and this virtual host
> is setup in Plesk. But, whether I try to browse to
> or without the virtual host
> to, I get the same problem.
> Below is the file that Plesk generated with the virtual domain:

If you want the JK forwarding to work for 
and your apache httpd configuration uses virtual hosts, you first have 
to identfy the VirtualHost block that configures the virtual host for and then put the JkMounts into that 
block. Non of the configuration items you included in your mail seem to 
match I guess, that one defined by

Include /var/www/vhosts/

the contents of which we don't know.



To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message