tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clinton J. Totten" <>
Subject RE: Setting ClientAuth parameter to true
Date Wed, 26 Sep 2007 12:51:18 GMT
I am currently doing the samething right now and am able to access porst
8443.  What is the error that you are getting?

-----Original Message-----
Sent: Wednesday, September 26, 2007 8:31 AM
Subject: Setting ClientAuth parameter to true



I am unable to set client authentication for SSL in tomcat 5.5.2. I have
generated the certificate for the client and imported the same into the
server's keystore so that the server can verify the client's
certificate. The following is the modification I make on server.xml.


    <Connector port="8443" maxHttpHeaderSize="8192"

               maxThreads="150" minSpareThreads="25"

               enableLookups="false" disableUploadTimeout="true"

               acceptCount="100" scheme="https" secure="true"

               clientAuth="true" sslProtocol="TLS" 


truststorePass="xxxxxx " />


once this change is done and the server is restarted, I am not able to
hit this url https://localhost:8443 <https://localhost:8443/> .


At the same time, if I change the value of clientAuth back to "false" I
am able to access the url.


Can some pls help where I went wrong?




This e-mail and any files transmitted with it are for the sole use of
the intended recipient(s) and may contain confidential and privileged
If you are not the intended recipient, please contact the sender by
reply e-mail and destroy all copies of the original message. 
Any unauthorized review, use, disclosure, dissemination, forwarding,
printing or copying of this email or any action taken in reliance on
this e-mail is strictly 
prohibited and may be unlawful.

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message