tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From soulboy <gjpidg...@gmail.com>
Subject Tomcat JNI Netbeans
Date Tue, 04 Sep 2007 08:30:24 GMT

Hi

I am having some trouble configuring a web application on Tomcat 6.0.14 that
is calling native
libs via JNI on Red Hat Ent 3.0.

I have not been able to configure it successfully and I am running out of
ideas.
I get errors like this

    java.lang.UnsatisfiedLinkError: Native Library WEB-INF/lib/libfoo.so
already loaded in another classloader 
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1525) 

And also ClassNotFound, also if I run everything from a standalone app it
works fine.

What discovered so far is this:

http://wiki.apache.org/tomcat/HowTo#head-a4b7185ee95d0cf14a48f92c08d1eb66b561139d

"one cannot place the native libraries OR their JNI interfaces under the
WEB-INF/lib or WEB-INF/classes directories "

"both this class and the shared library should be placed in the
$CATALINA_HOME/shared/lib directory."

Actually $CATALINA_HOME/shared/lib directory doesn't exist on my
installation so I created it and as test
I created and placed a dummy javalibrary in a .jar file in this location. I
created a dummy WebApplication
and included this library via the netbeans IDE and instanciated the library
class within the WebApps Serlet.

I noticed when I build the project with netbeans it copied and included the
java library into the WebApps .war
file (in the WEB-INF/lib directory structure which is not allowed for JNI
apps) . So I removed this before putting 
the .war file into the Tomcats WebApps directory.

I have tried both setting AND not setting the CLASSPATH env variable but
according to 

http://tomcat.apache.org/tomcat-6.0-doc/class-loader-howto.html

Tomcat ignores CLASSPATH anyway.

Does anyone have any ideas ?

Thanks

-- 
View this message in context: http://www.nabble.com/Tomcat-JNI-Netbeans-tf4376281.html#a12473998
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message