tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emsley, I \(Iain\)" <I.Ems...@rl.ac.uk>
Subject context.xml not being copied across on deployment
Date Fri, 17 Aug 2007 14:21:03 GMT
Dear Tomcat users, 
 
I'm very new to the Tomcat application and am trying to understand why
my context files are being ignored on deployment. I've had a search in
the mailing archives and read (and tried) the documentation on the
Tomcat site. 
 
I'm trying to get a calendaring system (which also uses Ant) to load its
applications from C:\foo\apache-tomcat-5.5.17\webapps. I've set  a build
file at c:\docs and settings\userid\foo.build.properties which links to
a foo.properties and foo.options.xml. These point to the context.xml
file in catalina home\web apps\META-INF\context.xml (I've posted one the
lines for the tomcat context:
org.bedework.app.Events.tomcat.context.xml=/META-INF/context.xml).
 
When I start Tomcat, the WAR files in webapps are deployed but the
context.xml files are ignored (they are required as I'm changing the
database from Hypersonic to MySQL). 
 
When I check the xml files in
\apache-tomcat-5.5.17\conf\Catalina\localhost, I'm still getting the
context for Hypersonic rather than MySQL. 
 
It appears that the WAR files are being copied in whole whilst my update
is being ignored. I would be grateful for some pointers as to what else
I can try to solve this issue and to learn from it for the future.
 
Many thanks, 
 
Iain
 
Iain Emsley
 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message