tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lakshmi Venkataraman" <>
Subject RE: [NOT SOLVED]Tomcat native library Not found in Solaris 9
Date Wed, 01 Aug 2007 22:30:05 GMT

Please give me some tips for compiling libtcnative on Solaris 9 without
the dynamic dependence on  We ship tomcat with our product.  On customer
installations, we cannot assume
that libgcc_s will be found in some standard location.

I have searched a lot on the web. I am also trying to compile gcc with
--disable-shared option.
I am running into some issues while trying to compile gcc. 
1) How to modify Tomcat native's configure script to link libgcc
2) What are the prerequisites before doing step 1)?

We are using Tomcat 5.5.23. I am using tcnative-1.1.8-src with


-----Original Message-----
From: Rainer Jung [] 
Sent: Sunday, May 13, 2007 1:45 AM
To: Tomcat Users List
Subject: Re: [SOLVED]Tomcat native library Not found in Solaris 9

It's very likely, that it depends on the same lib in RedHat. You can
check by using "ldd".

The difference is: gcc is a fundamental part of the OS with Linux, so is ususally installed in a standard library location for
Linux. Under Solaris it's an optional add-on installed in a separate

Personally I always find it anoying, that gcc put's a dependency on its
own runtime lib into the compiled code. You could prevent it doing so,
by changing its specs file (tehreby compiling in its convenience
routines statically).



Lakshmi Venkataraman wrote:
> I attached an eclipse debugger and found that an UnsatsfiedLinkError 
> was thrown due to the Fact that depends on 
> Then I included /usr/local/lib in LD_LIBRAY_PATH.
> Tomcat's Http11AprProtocol connector starts up without any problem.
> It is still not clear why on solaris 9 depends on 
> Whereas in Lunux redhat 4 it does NOT do do.
> Lakshmi
> -----Original Message-----
> From: Lakshmi Venkataraman []
> Sent: Saturday, May 12, 2007 5:33 PM
> To: Tomcat Users List
> Subject: RE: Tomcat native library Not found in Solaris 9
> I upgraded Tomcat to Tomcat 5.5.23 on Solaris 9. I also compiled 
> APR-1.2.8, tomcat-native-1.1.8-src and openssl-0.9.8b on Solaris.
> I have placed the in /export/home/lakshmi/Ivt55/bin.
> Ivt55 is the application directory and have INCLUDED it in 
> Yet Tomcat is unable to find  I get this message:
> The Apache Tomcat Native library which allows optimal performance in 
> production environments was not found on the java.library.path:
> /export/home/lakshmi/Ivt55/jre/lib/sparc/client:/export/home/lakshmi/I
> vt 
> 55/jre/lib/sparc:/export/home/lakshmi/Ivt55/jre/../lib/sparc:/export/h
> om 
> e/lakshmi/Ivt55/3rdPartyPackages/Tomcat/bin:/export/home/lakshmi/Ivt55
> /b in:/export/home/lakshmi/Ivt55/database::/usr/lib
> I did NOT have a problem on Linux redhat 4 or Windows.
> What else is missing on Solaris?
> Thanks in advance for your reply,
> Lakshmi

To start a new topic, e-mail: To unsubscribe,
For additional commands, e-mail:

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message