tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian Sutton <adr...@symphonious.net>
Subject Very Slow Startup with APR
Date Mon, 20 Aug 2007 23:35:54 GMT
Hi all,
I've been setting up Tomcat 5.5, with Java 5 on a Debian Etch server  
with a lot of success and just one problem - Tomcat seems to take a  
long time to load. I think the problem started when I installed APR/ 
tomcat native and enabled SSL through it but it's hard to pin point  
because the whole setup came together largely at once (it's a brand  
new server).

At one point the start up time was well under 10 seconds and it's now  
blown out to 5-15 minutes - but it does eventually come up. The last  
message in the log before the long delay is:
Aug 20, 2007 3:08:56 PM org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080

Once it starts the full startup logs look like:
Aug 20, 2007 3:08:56 PM org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Aug 20, 2007 3:22:17 PM org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8443
Aug 20, 2007 3:22:17 PM org.apache.coyote.ajp.AjpAprProtocol init
INFO: Initializing Coyote AJP/1.3 on ajp-8009
Aug 20, 2007 3:22:17 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 804697 ms
Aug 20, 2007 3:22:18 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Aug 20, 2007 3:22:18 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5
Aug 20, 2007 3:22:18 PM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
Aug 20, 2007 3:22:31 PM org.apache.coyote.http11.Http11AprProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Aug 20, 2007 3:22:31 PM org.apache.coyote.http11.Http11AprProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8443
Aug 20, 2007 3:22:32 PM org.apache.coyote.ajp.AjpAprProtocol start
INFO: Starting Coyote AJP/1.3 on ajp-8009
Aug 20, 2007 3:22:32 PM org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
Aug 20, 2007 3:22:32 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 14410 ms

Once it starts everything works fine and goes fast. Any pointers for  
how to track down the cause would be greatly appreciated.

Thanks,

Adrian Sutton
http://www.symphonious.net




---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message