tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Hanik - Dev Lists <devli...@hanik.com>
Subject Re: AW: AW: Problem calling the Web-Application by Alias name
Date Thu, 30 Aug 2007 09:28:11 GMT
http://dato.app.at
-->
port: 80
context: /


http://dato.at:8080/app
-->
port: 8080 
context: /app

does that paint the picture for you,
you are confusing too many things at the same time

Filip





Stasa Jerinic wrote:
> Yes I set the port 8080 in <Connector port..>.
> I think that I not anderstand you. I have now two ways to call my web-application.
> One is by the computer name (for example http://dato.at:8080/app) or the other way is
by the Alias that I inserted in the Host tag (http://dato.app.at).
> The calling by Alias name don't works really. The application is in fact loaded, but
I can not log me (when I trie to logg me on the web-page I get the side when logg me off and
in the browser URL is not more staying the http://dato.app.at but the http://dato.at:8080/app).
> What can be the problem? 
>
> Greetings,
> Jerinic Stasa
>
> the port (8080 vs 80) is not part of the hostname, but you set the port in
> <Connector port="..."
>
> element
>
> FIlip
>
> Stasa Jerinic wrote:
>   
>> I'm using only one Host. And I will to call the web-application not for example by
http://dato.at:8080/app but by http://dato.app.at  (dato.app.at I inserted as a Alias)
>>
>> Greetings,
>>
>> Jerinic Stasa
>>
>> if you are only using one <Host> element in server.xml, then you don't
>> need any aliases at all, get rid of them. all your requests will go to
>> that host/app anyway
>>
>>
>> filip
>>
>> Stasa Jerinic wrote:
>>  
>>     
>>> Hallo,
>>> I'm using Tomcat 5.0. For my web-application I use Hibernate, Struts and Struts-Layout
Frameworks.
>>> I have following problem:
>>> By starting my application with http://localhost:8080/app or http://my_computer_name:8080/app
I can normally work with application. I can log me and so on.
>>> But in server.xml I inserted in <Host ...> part the tag <Alias>domainname</Alias>.
By calling the web-application with dommainame that I inserted in Alias tag, I get the
>>> web-application but when I try to login me in the application it fails (same
behaviour like as the session is switched off).
>>> In the browser-URL I get also not more the domainname but the http://my_computer_name:8080/app.
>>> I tried to see what the problem can be with HTTPWatch. As soon the css with Struts-Layout
is loading the adress is changed from domainname to http://my_computer_name:8080/app.
>>> Have I forgot some settings in tomcat or the problem is lieing in Struts-Layout.
>>> Thanks.
>>> Greetings,
>>> Jerinic Stasa
>>>
>>> ------------------------------------------------------------------------
>>>
>>> No virus found in this incoming message.
>>> Checked by AVG Free Edition.
>>> Version: 7.5.484 / Virus Database: 269.12.12/979 - Release Date: 8/29/2007 8:21
PM
>>>
>>>    
>>>       
>> ---------------------------------------------------------------------
>> To start a new topic, e-mail: users@tomcat.apache.org
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
>>
>>  
>> ------------------------------------------------------------------------
>>
>> ---------------------------------------------------------------------
>> To start a new topic, e-mail: users@tomcat.apache.org
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>> ------------------------------------------------------------------------
>>
>> No virus found in this incoming message.
>> Checked by AVG Free Edition.
>> Version: 7.5.484 / Virus Database: 269.12.12/979 - Release Date: 8/29/2007 8:21 PM
>>  
>>     
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>
>
>   
> ------------------------------------------------------------------------
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> ------------------------------------------------------------------------
>
> No virus found in this incoming message.
> Checked by AVG Free Edition. 
> Version: 7.5.484 / Virus Database: 269.12.12/979 - Release Date: 8/29/2007 8:21 PM
>   


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message