tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "" <>
Subject Re: - Error -404 resources not found
Date Sat, 18 Aug 2007 16:32:19 GMT

I installed tomcat and:
1. I named  the environmental variable to JAVA_HOME and it was set   to c:\Program Files\Java\jdk1.6.0_01

2 I edited the context.xml  configuration file and added reloadable="true" to the  <context
> tag. 
I changed it to <Context  reloadable="true">

3 I went to the web.xml file to de-comment the invoker servlet:


  4. Next I de-commented the:

    5. I then created a class directory at: C:\TomCat\webapps\ROOT\WEB-INF
       once there I created a folder named----classes.

When I start TomCat from the command prompt I get server startup in 2092 ms. (Seems Successful)

But still when I open my browser and type http://localhost:8080/   I get HTTP Status 404 -
/ The requested resource (/) is not available.

I'm a little stumped because I have done every possible thing that TomCat has given in the
troubleshooting section of their documentation and also I have uninstalled JDK and TomCat
on a couple of machines but still the same response. So it must be something I'm doing wrong,
but I have no idea what it is. I have tried numerous of combinations and even tried fresh

Any Thoughts would be appreciated

 --- On Sat 08/18, Hassan Schroeder < > wrote:
From: Hassan Schroeder [mailto:]
Date: Sat, 18 Aug 2007 07:25:56 -0700
Subject: Re: - Error -404 resources not found

On 8/18/07, <> wrote:> I just installed TomCat
(6 .*.) on a Windows XP server:>>  1. I setup the system variables Java_Home to my JDK
(Not JDK Bin)it''s JAVA_HOME., not Java_Home -- case sensitiveDoes the base Tomcat install
work? Welcome page, examples, etc.?>  2.  I edited my Context.xml file second tag line
to <Context reloadable="true">it's context.xml, not Context.xml -- case sensitive --
and what do you meanby "second tag line"?  a context.xml file should contain <Context/>
as theroot element.>  3. And I commented out some lines Web.xml files (mapping,invoking)It's
'web.xml', not Web.xml -- and is this in your webapp or some other?>  When I run TOMCat
from the command line, it loads properly with no problem, but when I open up Any browser (firefox,
internet explorer)  I get an error -404 resources not found.And you're sure you don't have
a firewall preventing access to theport Tomcat is using?-- Hassan Schroeder 

Join Excite! -
The most personalized portal on the Web!

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message