tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dale_Robe...@scee.net
Subject Re: iPlanet / SunONE web server tomcat connector connection re-use disabled
Date Thu, 19 Jul 2007 08:58:27 GMT
Just as a courtesy in case anyone wonders the outcome of this thread:

I have tested the latest subversion development iPlanet connector 
indicated by Rainer (compiled using Sun's compiler but gnu make - also 
updated to link with Sun's compiler rather than ld .... as recommended in 
the man page for the Sun compiler). This latest version with patches 
including "un disabling" of connection pooling appears to work quite 
happily in our test environment. I will roll it out to production when the 
next stable release is done most likely.

Using the stable 1.2.23 release with just the "un disabling" "fixed", 
compiled in the same way, in production has so far managed to hold it's 
own without great issue. There are a number of what I believe are spurious 
log entries regarding tomcat servers being unavailable, and only around 30 
odd connections ever seem to get held open at any one time despite having 
64 set in my workers.properties (included below - and hopefully not 
misconfigured - the XX are intentionally to hide IP's). However, so far 
this doesn't appear to have adversely effected things.

As an indicator, the site we run is fairly busy, with only a small subset 
of content being served by the tomcat servers, but still we get around 7 
million hits a day handled by our 3 tomcat servers.

worker.list=jknsapiworker
worker.host1.port=8009
worker.host1.host=XX.XX.XX.0
worker.host1.type=ajp13
worker.host1.lbfactor=1
worker.host1.socket_keepalive=True
worker.host1.socket_timeout=30
worker.host1.prepost_timeout=5000
worker.host1.reply_timeout=180000
worker.host1.connection_pool_size=64
worker.host1.connection_pool_timeout=600
worker.host2.port=8009
worker.host2.host=XX.XX.XX.1
worker.host2.reference=worker.host1
worker.host3.port=8009
worker.host3.host=XX.XX.XX.2
worker.host3.reference=worker.host1
worker.jknsapiworker.type=lb
worker.jknsapiworker.balance_workers=host1,host2,host3


Dale Roberts
Sony Computer Entertainment Europe
http://www.scee.com


Dale_Roberts@scee.net 
09/07/2007 09:55

Please respond to
"Tomcat Users List" <users@tomcat.apache.org>


To
"Tomcat Users List" <users@tomcat.apache.org>
cc

Subject
Re: iPlanet / SunONE web server tomcat connector connection re-use 
disabled






Hi Rainer,

Many thanks for the feedback.

To answer your question on stability, without the connection pooling being 

"un disabled"  the connector appears stable until placed under load at 
which point it starts to flag all tomcat instances as "down", which they 
are not. (I don't believe this is a result of over busy back-end tomcat 
servers though based on some preliminary observations of number of 
connections, tomcat logs, tomcat server performance etc). Unfortunately I 
couldn't give you any figures on how much load is required (we have a 
system under light load and a system under heavy load and nothing to "test 

the middle ground"). However, with the connection pooling "un disabled" it 

appears to work much better having run for most of the day on our heavy 
load system without issue before being "rolled out" for operational 
reasons not related to stability.

To answer your question about ongoing support for the iPlanet / SunONE 
connector, from an ongoing support point of view I think that's really a 
matter of how many people use iPlanet and how hard it is to maintain. That 

said, I for one appreciate the fact there is a connector. The only other 
option I can see is to configure one of the proxy forwarding modules of 
iPlanet available for Sun, but I suspect that wouldn't facilitate 
connection pooling and would thus provide lower performance and I had 
trouble trying to download it anyway.

As to bugzilla and patches, I will do my best (I have signed up for a 
bugzilla account today so I can open a bug to track this). However I feel 
I should point out that I'm not a developer. My last proper C experience 
was a university (and that was C++) over 10 years ago. So I know enough to 

read some code and was able to find this "possible bug" but I fear I might 

do more damage than good if let loose on source code "for real". I work at 

the infrastructure level (more an end use of the connector). So apologies 
in advance if I don't contribute to further updates and fixes but I will 
try to provide the specifics of the update I made in suitable format in 
the bugzilla report when I raise it.

Dale Roberts
Sony Computer Entertainment Europe
http://www.scee.com


Rainer Jung <rainer.jung@kippdata.de> 
07/07/2007 13:33

Please respond to
"Tomcat Users List" <users@tomcat.apache.org>


To
Tomcat Users List <users@tomcat.apache.org>
cc

Subject
Re: iPlanet / SunONE web server tomcat connector connection re-use 
disabled






Hi Dale,

thanks for digging into this. In fact the Netscape/Sun connector is not 
in very good shape at the moment. The amount of work that will go into 
it, to bring it into a better shape depends on people like you, that are 
going to help us. The Netscape/Sun community seemed to almost 
non-existant for many months and only recently a few people showed up 
and asked questions about the connector.

Would you please open a bugzilla for your observation and add your 
changes as a patch to it? This way it is more likely, that we will 
remember this as an open point.

You might also like to check out jk from subversion and build the 
Netscape connector from this version. I added some enhancements/bug 
fixes which will be released with version 1.2.24.

What is your general impression about the Netscape connector? Is it 
working stable for you? Do you think it is worthwhile supporting it in 
the future?

Concerning your question: I think the missing connection reuse is just a 
historic oversight. Enabling it needs some testing though in order to 
ensure it runs well.

Regards,

Rainer

Dale_Roberts@scee.net wrote:
> Hi,
> 
> BACKGROUND:
> 
> I have been using the tomcat connector for Netscape / SunONE web server 
> from the tomcat-connectors-1.2.23-src bundle available from the main 
> tomcat site. I have found that connections are not being re-used by the 
> connector. i.e. the connector opens a separate connection to tomcat for 
> each and every request it's configured to pass to tomcat and then closes 


> that connection after receiving it's response.
> 
> When I enable debug logging for the connector I see messages telling me 
> that connection re-use is disabled. I found reference to an option for 
> apache to disable re-use but nothing for Netscape. Looking at the source 


> code I find that all but the Netscape connector appear to have a 
> "s->disable_reuse = JK_FALSE;" statement in the "init_ws_service" 
function 
> in the connector source code file (jk_nsapi_plugin.c for Netscape). 
> 
> As a test I have added this to the Netscape connector and re-compiled 
and 
> it now re-uses connections which is an obvious performance gain (I'm 
> assuming here as I haven't benchmarked anything). The implication is 
that 
> someone either explicitly set re-use to be disabled for Netscape, 
> presumably due to problems not immediately obvious if re-use is 
enabled,, 
> or someone changed the common code to make re-use optional but forgot to 


> enable it by default in the Netscape connector. I only suggest the 
latter 
> as there is no immediately obvious indication that it is intentionally 
> disable in Netscape and the plug-in seems to work with it enabled after 
> some very brief testing.
> 
> QUESTION:
> 
> Can anyone confirm or deny whether the Netscape connector should not 
have 
> connection re-use enabled as the other connectors do. Some overview of 
any 
> reason would also be much appreciated.
> 
> Many Thanks in advance.
> 
> Dale Roberts

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org



**********************************************************************
This email and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed. 
If you have received this email in error please notify postmaster@scee.net
This footnote also confirms that this email message has been checked for 
all known viruses.
Sony Computer Entertainment Europe Limited
Registered Office: 10 Great Marlborough Street, London W1F 7LP, United 
Kingdom
Registered in England: 3277793
**********************************************************************


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message