tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Sweet <sw...@sfos.uaf.edu>
Subject problem I don't know how to summarize for this subject line
Date Wed, 11 Jul 2007 20:02:09 GMT
I have a web app written by another developer that I am trying to deploy 
with Tomcat.  The app utilizes jsp and jsf elements.  I am experiencing 
strange behavior with a portion of the application, however only when it 
is run through the public domain name; when I run it on the server 
through the "http://localhost/" URL it all works flawlessly.

Overall with the public URL 98% of the app works fine.  However there 
are two functions of the app that experience a strange behavior.  When I 
attempt to submit the page the forwarded URL becomes "http://edit.jsf/" 
instead of "http://mydomain.org/edit.jsf" -- but only when run through 
the public URL and only those two pages.  When I am doing it on the 
server using "localhost" the troublesome pages properly forward to 
"http://localhost:8080/edit.jsf" and every other page in the app 
forwards properly with both public and localhost URLs.

I have been back and forth through the source code and spent a fair 
amount of time trying to determine if it is a Javaserver Faces problem 
and can find no evidence that it is.  The fact that it works with 
localhost seems (to me) to point away from a jsf problem, however this 
is my first real experience with jsf.  I have asked on some jsf lists 
and gotten no input.  I have also tried with Tomcat 5.5.17, 5.5.23, and 
6.0.10 and experienced identical behavior.  The original developer does 
not experience this on his system which limits his ability to help me 
figure it out.

I am not a complete newbie with Tomcat but my experience to date has 
been pretty straightforward.  Does anything about this ring any bells to 
anyone?  Even any suggestions about where to look would be appreciated.

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message