tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Hanik - Dev Lists <devli...@hanik.com>
Subject Re: Tomcat 5.5 Clustering issues
Date Mon, 09 Jul 2007 19:04:30 GMT
not really, try to lower your mcastFrequency value, and increase your 
mcastDropTime value

Filip

Andrew R Feller wrote:
> Filip,
>
> Perhaps you can explain why each of these log messages are happening
> every 10 minutes?  If this isn't controlled behavior, which I doubt,
> then something is going on here. =P
>
> Thanks for the help,
> Andy
>
> 2007-07-09 09:30:09,497 INFO
> [org.apache.catalina.cluster.tcp.SimpleTcpCluster] - Replication member
> added:org.apache.catalina.cluster.mcast.McastMember[tcp://130.39.186.177
> :9001,catalina,130.39.186.177,9001, alive=248399]
>
> 2007-07-09 09:30:09,509 DEBUG
> [org.apache.catalina.cluster.tcp.DataSender] - Create sender
> [/130.39.186.177:9,001]
>
> 2007-07-09 09:30:14,646 INFO
> [org.apache.catalina.cluster.tcp.SimpleTcpCluster] - Received member
> disappeared:org.apache.catalina.cluster.mcast.McastMember[tcp://130.39.1
> 86.177:9001,catalina,130.39.186.177,9001, alive=248399]
>
> 2007-07-09 09:40:09,733 INFO
> [org.apache.catalina.cluster.tcp.SimpleTcpCluster] - Replication member
> added:org.apache.catalina.cluster.mcast.McastMember[tcp://130.39.186.177
> :9001,catalina,130.39.186.177,9001, alive=848625]
>
> 2007-07-09 09:40:09,733 DEBUG
> [org.apache.catalina.cluster.tcp.DataSender] - Create sender
> [/130.39.186.177:9,001]
>
> 2007-07-09 09:40:15,064 INFO
> [org.apache.catalina.cluster.tcp.SimpleTcpCluster] - Received member
> disappeared:org.apache.catalina.cluster.mcast.McastMember[tcp://130.39.1
> 86.177:9001,catalina,130.39.186.177,9001, alive=848625]
>
> 2007-07-09 09:50:09,935 INFO
> [org.apache.catalina.cluster.tcp.SimpleTcpCluster] - Replication member
> added:org.apache.catalina.cluster.mcast.McastMember[tcp://130.39.186.177
> :9001,catalina,130.39.186.177,9001, alive=150900]
>
> 2007-07-09 09:50:09,939 DEBUG
> [org.apache.catalina.cluster.tcp.DataSender] - Create sender
> [/130.39.186.177:9,001]
>
> 2007-07-09 09:50:15,362 INFO
> [org.apache.catalina.cluster.tcp.SimpleTcpCluster] - Received member
> disappeared:org.apache.catalina.cluster.mcast.McastMember[tcp://130.39.1
> 86.177:9001,catalina,130.39.186.177,9001, alive=150900]
>
> 2007-07-09 10:10:10,800 INFO
> [org.apache.catalina.cluster.tcp.SimpleTcpCluster] - Replication member
> added:org.apache.catalina.cluster.mcast.McastMember[tcp://130.39.186.177
> :9001,catalina,130.39.186.177,9001, alive=1351729]
>
> 2007-07-09 10:10:10,800 DEBUG
> [org.apache.catalina.cluster.tcp.DataSender] - Create sender
> [/130.39.186.177:9,001]
>
> 2007-07-09 10:10:15,840 INFO
> [org.apache.catalina.cluster.tcp.SimpleTcpCluster] - Received member
> disappeared:org.apache.catalina.cluster.mcast.McastMember[tcp://130.39.1
> 86.177:9001,catalina,130.39.186.177,9001, alive=1351729]
>
> 2007-07-09 10:20:10,832 INFO
> [org.apache.catalina.cluster.tcp.SimpleTcpCluster] - Replication member
> added:org.apache.catalina.cluster.mcast.McastMember[tcp://130.39.186.177
> :9001,catalina,130.39.186.177,9001, alive=1951799]
>
> 2007-07-09 10:20:10,833 DEBUG
> [org.apache.catalina.cluster.tcp.DataSender] - Create sender
> [/130.39.186.177:9,001]
>
> 2007-07-09 10:20:16,061 INFO
> [org.apache.catalina.cluster.tcp.SimpleTcpCluster] - Received member
> disappeared:org.apache.catalina.cluster.mcast.McastMember[tcp://130.39.1
> 86.177:9001,catalina,130.39.186.177,9001, alive=1951799]
>
> Andrew R Feller, Analyst
> Subversion Administrator
> University Information Systems
> Louisiana State University
> afelle1@lsu.edu
> (office) 225.578.3737
>
> -----Original Message-----
> From: Filip Hanik - Dev Lists [mailto:devlists@hanik.com] 
> Sent: Monday, July 09, 2007 9:34 AM
> To: Tomcat Users List
> Subject: Re: Tomcat 5.5 Clustering issues
>
> correct, on the multicast IP
>
> Filip
>
> Andrew R Feller wrote:
>   
>> Is the multicast heartbeat picked up over the multicast IP or the
>> Receiver address that is broadcasted?  I assume it is the multicast IP
>> as the Receiver is supposedly used for replication only.
>>
>> Andrew R Feller, Analyst
>> Subversion Administrator
>> University Information Systems
>> Louisiana State University
>> afelle1@lsu.edu
>> (office) 225.578.3737
>> -----Original Message-----
>> From: Filip Hanik - Dev Lists [mailto:devlists@hanik.com] 
>> Sent: Tuesday, July 03, 2007 9:55 AM
>> To: Tomcat Users List
>> Subject: Re: Tomcat 5.5 Clustering issues
>>
>> the disappeared message appears 3seconds after the member added
>>     
> message.
>   
>> 3 seconds is the timeout you have set, ie, if no multicast heartbeat
>>     
> is 
>   
>> received after 3 seconds, consider the member dead.
>> so it seems like multicasting is not working properly on your system.
>>
>> Filip
>>
>> Andrew R Feller wrote:
>>   
>>     
>>> Good morning everyone,
>>>
>>>  
>>>
>>> I have been trying to get Tomcat clustering between two Tomcat
>>>     
>>>       
>> instances
>>   
>>     
>>> set up, but I have run into some issues.  After opening the necessary
>>> ports in the firewall, routing the broadcast messages to the correct
>>> network interface (eth0), and setting up server.xml with the
>>>       
> necessary
>   
>>> membership information, I get the following from my Tomcat logs:
>>>
>>>  
>>>
>>> 2007-07-03 09:16:37,247 INFO
>>> [org.apache.catalina.cluster.tcp.SimpleTcpCluster] - Replication
>>>     
>>>       
>> member
>>   
>>
>>     
> added:org.apache.catalina.cluster.mcast.McastMember[tcp://130.39.184.173
>   
>>   
>>     
>>> :4001,catalina,130.39.184.173,4001, alive=30318]
>>>
>>> 2007-07-03 09:16:37,256 DEBUG
>>> [org.apache.catalina.cluster.tcp.DataSender] - Create sender
>>> [/130.39.184.173:4,001]
>>>
>>> 2007-07-03 09:16:40,724 INFO
>>> [org.apache.catalina.cluster.tcp.SimpleTcpCluster] - Received member
>>>
>>>     
>>>       
> disappeared:org.apache.catalina.cluster.mcast.McastMember[tcp://130.39.1
>   
>>   
>>     
>>> 84.173:4001,catalina,130.39.184.173,4001, alive=30318]
>>>
>>>  
>>>
>>> What could be the cause of cluster members disappearing immediately
>>> after being added?  Am I missing anything necessary for setting up
>>> clustering / session replication?  Relative information about the
>>>     
>>>       
>> server
>>   
>>     
>>> is below.
>>>
>>>  
>>>
>>> Thank you,
>>>
>>> Andrew
>>>
>>>  
>>>
>>> Tomcat: 5.5.23
>>>
>>> Server: RHEL 5
>>>
>>> Server.xml:
>>>
>>>  
>>>
>>>     <Cluster
>>> className="org.apache.catalina.cluster.tcp.SimpleTcpCluster"
>>>
>>>  
>>> managerClassName="org.apache.catalina.cluster.session.DeltaManager"
>>>
>>>         expireSessionsOnShutdown="false"
>>>
>>>         useDirtyFlag="true">
>>>
>>>  
>>>
>>>         <Membership
>>>
>>>
>>>       
> className="org.apache.catalina.cluster.mcast.McastService"
>   
>>>             mcastAddr="239.39.184.173"
>>>
>>>             mcastPort="45564"
>>>
>>>             mcastFrequency="500"
>>>
>>>             mcastDropTime="3000" />
>>>
>>>  
>>>
>>>         <Receiver
>>>
>>>  
>>> className="org.apache.catalina.cluster.tcp.ReplicationListener"
>>>
>>>             tcpListenAddress="auto"
>>>
>>>             tcpListenPort="4001"
>>>
>>>             tcpSelectorTimeout="100"
>>>
>>>             tcpThreadCount="6" />
>>>
>>>  
>>>
>>>         <Sender
>>>
>>>  
>>> className="org.apache.catalina.cluster.tcp.ReplicationTransmitter"
>>>
>>>             replicationMode="synchronous" />
>>>
>>>  
>>>
>>>             <Valve
>>> className="org.apache.catalina.cluster.tcp.ReplicationValve"
>>>
>>>  
>>>
>>>     
>>>       
> filter=".*\.gif;.*\.js;.*\.jpg;.*\.png;.*\.htm;.*\.html;.*\.css;.*\.txt;
>   
>>   
>>     
>>> " />
>>>
>>>  
>>>
>>>         <ClusterListener
>>>
>>>       
> className="org.apache.catalina.cluster.session.ClusterSessionListener"
>   
>>> />
>>>
>>>  
>>>
>>>     </Cluster>
>>>
>>>  
>>>
>>> IP table rules:
>>>
>>>  
>>>
>>>     -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport
>>> 4001 -j ACCEPT
>>>
>>>     -A RH-Firewall-1-INPUT -p udp --dport 45564 -d 239.39.184.173 -j
>>> ACCEPT
>>>
>>>
>>>   
>>>
>>>     
>>>       
> ------------------------------------------------------------------------
>   
>>   
>>     
>>> No virus found in this incoming message.
>>> Checked by AVG Free Edition. 
>>> Version: 7.5.476 / Virus Database: 269.9.14/884 - Release Date:
>>>     
>>>       
>> 7/2/2007 3:35 PM
>>   
>>     
>>>   
>>>     
>>>       
>> ---------------------------------------------------------------------
>> To start a new topic, e-mail: users@tomcat.apache.org
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
>> ---------------------------------------------------------------------
>> To start a new topic, e-mail: users@tomcat.apache.org
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
>>
>>   
>>     
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>
>
>   


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message