tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Craig Skinner <craig.skin...@kepax.co.uk>
Subject Re: tomcat-4.1 & kaffe; IllegalArgumentException: Attribute must be readable or writable
Date Wed, 25 Jul 2007 15:18:01 GMT
On Wed, Jul 25, 2007 at 09:37:21AM -0500, Caldarale, Charles R wrote:
> > Not an option: Sun does not release a JKD for BSD.
> 
> If you can upgrade to Tomcat 5.5, you only need a JRE, not a JDK,

Oh? That's a new one on me. I thought that JSP's are complied at run
time. I have jikes installed.

> and there are Linux-compatible JREs downloadable from Sun.

> > Not an option: Sun does not release a JKD for BSD.

Linux is not BSD compatible, in the same way that Solaris SPARC binaries
will not run on i386 Linux.

> Actually, even
> with Tomcat 4.1, the only part of the JDK that's needed for Tomcat is
> the javac classes from tools.jar, which are all pure Java and can be
> used independently of the rest of the JDK.
> 

I don't think that there is a problem with the complier, else I would
not be getting this:

$ ls  -lh /var/tomcat/work/Standalone/localhost/_/
total 36
-rw-r--r--  1 _tomcat  _tomcat    81B Jul 21 13:06 SESSIONS.ser
-rw-r--r--  1 _tomcat  _tomcat  14.6K Jul 21 13:05 index_jsp.java

I think there is some silly mis-config, or file system permission error
as:

javax.management.RuntimeOperationsException: nested exception is java.lang.IllegalArgumentException:
Attribute must be readable or writable
java.lang.IllegalArgumentException: Attribute must be readable or writable
   at javax.management.MBeanAttributeInfo.<init> (MBeanAttributeInfo.java:60)

I searched for this exception and did not get anything relevant. Any
other ideas? Thanks.

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message