tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "tom northcutt" <tno...@gmail.com>
Subject Fwd: building mod_jk 1.2.23 apxs errors
Date Thu, 07 Jun 2007 19:12:52 GMT
I am attempting to compile the latest version of mod_jk for integration
with my apache 2.0.59 server on CentOS-3.8 (32bit)

After running  ./configure --with-apxs=/usr/local/apache/bin/apxs
from the native directory, the mod_jk.lai and mod_jk.a files are
created.

Upon running the make install, I get the following error:

****
Installing files to Apache Modules Directory...
/usr/local/apache/bin/apxs -i mod_jk.la
/usr/local/apache-2.0.59/build/instdso.sh
SH_LIBTOOL='/usr/local/apache-2.0.59/build/libtool' mod_jk.la
/usr/local/apache-2.0.59/modules
/usr/local/apache-2.0.59/build/libtool --mode=install cp mod_jk.la
/usr/local/apache-2.0.59/modules/
cp .libs/mod_jk.lai /usr/local/apache-2.0.59/modules/mod_jk.la
cp .libs/mod_jk.a /usr/local/apache-2.0.59/modules/mod_jk.a
ranlib /usr/local/apache-2.0.59/modules/mod_jk.a
chmod 644 /usr/local/apache-2.0.59/modules/mod_jk.a
PATH="$PATH:/sbin" ldconfig -n /usr/local/apache-2.0.59/modules
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/local/apache-2.0.59/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
Warning!  dlname not found in /usr/local/apache-2.0.59/modules/mod_jk.la.
Assuming installing a .so rather than a libtool archive.
chmod 755 /usr/local/apache-2.0.59/modules/mod_jk.so
chmod: failed to get attributes of
`/usr/local/apache-2.0.59/modules/mod_jk.so': No such file or
directory
apxs:Error: Command failed with rc=65536
****.

If I run this command (from the Makefile) manually, I get the same error:

(in apache-2.0)
 /usr/local/apache/bin/apxs -i mod_jk.la


My apxs was built from source with the following apache configuration:
configured by ./configure, generated by GNU Autoconf 2.59,
  with options \"'--prefix=/usr/local/apache-2.0.59' '--enable-module=most' '--e
nable-shared=max' '--enable-proxy' '--enable-rewrite'\"

Thanks,

-Tom

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message