tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Delbecq <delbd+jaka...@oma.be>
Subject Re: [OT] new guy. error in catalina.out
Date Thu, 28 Jun 2007 13:10:34 GMT
As it's written, your framework (slide) is trying to create an illegal
xml document. I suggest you refere to the mailing list of that tool.
This is not a tomcat related problem.

En l'instant précis du 28/06/07 15:07, Vaduvoiu Tiberiu s'exprimait en
ces termes:
> First of all hi to everyone since I'm new to the list. Who can help me with the following
problem:
>
> i'm developing a site using hippo repository on tomcat 6.0.13 I'm having this error in
catalina.out when I try to display a xml search with dasl:
>
> org.jdom.IllegalDataException: The data "
>
> ...some text that contains è, à....
>
> " is not legal for a JDOM character content: 0x19 is not a legal XML character.
>  at org.jdom.Text.setText(Text.java:188)
>  at org.jdom.Text.<init>(Text.java:99)
>  at org.jdom.Element.setText(Element.java:630)
>  at org.apache.slide.webdav.util.PropertyRetrieverImpl.getPropertyElement(PropertyRetrieverImpl.java:605)
>  at org.apache.slide.webdav.util.PropertyRetrieverImpl.getPropertyElement(PropertyRetrieverImpl.java:540)
>  at org.apache.slide.webdav.util.PropertyRetrieverImpl.getRequestedPropertiesOfObject(PropertyRetrieverImpl.java:371)
>  at org.apache.slide.webdav.util.PropertyRetrieverImpl.getPropertiesOfObject(PropertyRetrieverImpl.java:308)
>  at org.apache.slide.webdav.method.SearchMethod$WebdavResult.init(SearchMethod.java:408)
>  at org.apache.slide.webdav.method.SearchMethod$WebdavResult.<init>(SearchMethod.java:350)
>  at org.apache.slide.webdav.method.SearchMethod.executeRequest(SearchMethod.java:223)
>  at org.apache.slide.webdav.method.AbstractWebdavMethod.run(AbstractWebdavMethod.java:405)
>  at org.apache.slide.webdav.WebdavServlet.service(WebdavServlet.java:151)
>  at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
>  at nl.hippo.repository.WebdavRequestHandler.handle(WebdavRequestHandler.java:187)
>  at nl.hippo.repository.FortressServletContainer.handleRequest(FortressServletContainer.java:65)
>  at nl.hippo.repository.FortressServlet.service(FortressServlet.java:117)
>  at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
>  at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
>  at nl.hippo.repository.SlideRealmFilter.doFilter(SlideRealmFilter.java:165)
>  at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
>  at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
>  at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
>  at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
>  at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
>  at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
>  at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
>  at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:261)
>  at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
>  at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
>  at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:767)
>  at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:697)
>  at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:889)
>  at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:686)
>  at java.lang.Thread.run(Thread.java:595)
>
> so from what I understand, tomcat has a problem with the fact that some of my xml contain
characters that are not allowed.
>
> does anyone know how to solve this? as I remember my xml documents are version 1.1 and
in version 1.1 0x19 characters are allowed. Although this might be considered as an xml specific
question I asked here because I get this error "because" of tomcat. If I run the repository
without tomcat then I have no problem. 
> 10x in advance
>
>
>        
> ____________________________________________________________________________________
> Yahoo! oneSearch: Finally, mobile search 
> that gives answers, not web links. 
> http://mobile.yahoo.com/mobileweb/onesearch?refer=1ONXIC
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>   


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message