tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Schönhaber <mailing-tomcat-u...@schoenhaber.de>
Subject Re: Problem with XSL stylesheet not being applied when XML served through Tomcat
Date Wed, 13 Jun 2007 09:27:45 GMT
Garey wrote:

> http://library11.berkeley.edu/~gmills/binds_result.xml 
> <http://library11.berkeley.edu/%7Egmills/binds_result.xml>
> 
> http://library11.berkeley.edu:8080/...inds_result.xml 
> <http://library11.berkeley.edu:8080/noidbind/binds_result.xml>
> 
> 
> In Firefox 2, the first URL results in the XSL stylesheet referenced in 
> the XML document being applied correctly. The second URL does not. The 
> difference is that the first URL is being served by Apache httpd 1.3.X, 
> and the second by Tomcat 6.0.

I don't think this has anything to do with Tomcat. It rather seems to me
that Firefox loads and applies the XSL if the URL referencing it points
to the same server(?) / base URL (?) the XML file comes from.
Drop the XSL into the Tomcat webapp and modify the XML source (or our
code generating it) to reference it from there. Then it will propably be
applied.
If you find out whether this is a documented feature of Firefox or
simply a bug, please let me know.

Regards
  mks

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message