tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Hanik - Dev Lists <devli...@hanik.com>
Subject Re: APR not working
Date Fri, 01 Jun 2007 17:45:26 GMT
you might have the wrong version of APR or tcnative,
when the system stops, do a kill -3 on the process to get the thread dump

Filip

mljv@planwerk6.de wrote:
> TOMCAT: 6.0.13 
> OS: linux-2.6.18-4-686 
> JAVA: java-1.5.0-sun-1.5.0.10 
>
> i tried to run with APR, followed 
> http://tomcat.apache.org/tomcat-6.0-doc/apr.html
> ./configure && make && make install worked fine
> starting tomcat with 
> CATALINA_OPTS="-Djava.awt.headless=true -Xmx128M -server -Djava.library.path=/usr/local/apr/lib"
> In my logs tomcat is starting up and shows 
> INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters [false], 
> random [true].
> as last line. No connector starts. When i try "telnet localhost 8080" => 
> Connection refused
>
> when i drop -Djava.library.path=/usr/local/apr/lib from OPTS it starts up 
> without APR and i can connect on port 8080
>
> Did i miss something to get APR running?
> Can someone help me to get APR running?
>
> kind regards,
> janning
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>
>
>   


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message