tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean_McKell...@agsea.com
Subject Re: Tomcat 6.0 on Windows Server 2003 IIS 6.0 connector not functioning
Date Fri, 11 May 2007 22:26:12 GMT
I set up and allowed the extension.  I even set IIS to allow all ISAPI
extensions.
I've even set the CATALINA_HOME tree to Everyone - Full Control and
still no ISAPI log and no errors in any of the other logs or system event
logs.

If I can at least get the log to work, I'll have something to work on.
I've found
quite a few similar problems in the archives and other sites, but no
working solution.

Thank you for the suggestion, got any others?

Sean McKellips
Systems Administrator
Associated Grocers
206-767-8725 phone
206-764-7879 fax
sean_mckellips@agsea.com


                                                                           
             hobbyist@comcast.                                             
             net                                                           
                                                                        To 
             05/11/2007 02:08          users@tomcat.apache.org             
             PM                                                         cc 
                                                                           
                                                                   Subject 
             Please respond to         Re: Tomcat 6.0 on Windows Server    
               "Tomcat Users           2003 IIS 6.0 connector not          
                   List"               functioning                         
             <users@tomcat.apa                                             
                 che.org>                                                  
                                                                           
                                                                           
                                                                           
                                                                           




Have you configured the Web Service Extension?


I can't access Tomcat content through IIS.  The troubleshooting steps
on the IIS How-to were insufficient to identify my problem.

What am I missing?

A few bits of relevant information:

The isapi log file does not get created.
I've verified that the registry settings are correct for the redirector.
I also tried using isapi_redirect.properties, with no success.
The ISAPI filter on the default web site shows loaded (green arrow), high
priority.
The urimappings reference the worker in the workers.properties file.
The port for the work matches in the workers file and the server.xml file.
Directory browsing is enabled for both the website and the jakarta
directory.
The Catalina log shows it is listening on the right port, but Jk running
ID=0

Thanks!

Various relevant files and log entries:

Problem:
http://localhost:8080/examples      works
http://localhost/examples           doesn't work

Info:

ISAPI information:
isapi_redirect.dll v1.2.22.0

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi
Redirector]

[HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi
Redirector\1.0]
"extension_uri"="/jakarta/isapi_redirect.dll"
"log_file"="C:\\Program Files\\Apache Software Foundation\\Tomcat 6.0
\\logs\\isapi.log"
"log_level"="debug"
"worker_file"="C:\\Program Files\\Apache Software Foundation\\Tomcat 6.0
\\conf\\workers.properties"
"worker_mount_file"="C:\\Program Files\\Apache Software Foundation\\Tomcat
6.0\\conf\\uriworkermap.properties"


workers.properties:

worker.list=ajp13w

worker.ajp13w.type=ajp13
worker.ajp13w.host=localhost
worker.ajp13w.port=8009


uriworkermap.properties:

/servlets-examples*=ajp13w          #tried leaving off trailing slash as
suggested in archives
/examples/*=ajp13w

!/servlets-examples/*.jpeg=ajp13w


server.xml
...
  <Service name="Catalina">
    <Connector port="8080" protocol="HTTP/1.1"
               maxThreads="150" connectionTimeout="20000"
               redirectPort="8443" />
    <Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true"
               maxThreads="150" scheme="https" secure="true"
               clientAuth="false" sslProtocol="TLS" />
    <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />
...

On IIS:
Default Web Site and Jakarta Virtual Directory:
Directory browsing enabled
Anonymous access enabled
Jakarta virtual directory allows scripts and executables

IIS Log:
#Fields: date time s-sitename s-ip cs-method cs-uri-stem cs-uri-query
s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus
sc-win32-status
2007-05-09 22:23:17 W3SVC1 127.0.0.1 GET /examples/ - 80 - 127.0.0.1
Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+SV1;+.NET+CLR+1.1.4322)
404 0 2

Catalina log:
May 9, 2007 3:23:09 PM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
May 9, 2007 3:23:09 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/94  config=null

Sean McKellips
Systems Administrator
Associated Grocers
206-767-8725 phone
206-764-7879 fax
sean_mckellips@agsea.com


NOTICE:  This email message is for the sole use of the intended
recipient(s) and may contain confidential and privileged information.  Any
unauthorized review, use, disclosure or distribution is prohibited.  If you
are not the intended recipient, please contact the sender by reply email
and destroy all copies of the original message.  Thank you.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org




---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message