tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lakshmi Venkataraman" <laks...@foundrynet.com>
Subject RE: Connection refused when using Tomcat 6.0.10 with APR ...
Date Sun, 06 May 2007 05:48:57 GMT
I  posted a similar email asking abour Connection Refuesed question
under a different thread.
I have also summarised my findings.  Can you take a look?
The subject is  "Tomcat 5.5, IPv6, APR, HTTP and HTTPS"


--Thanks
Lakshmi

-----Original Message-----
From: Mladen Turk [mailto:mladen.turk@gmail.com] 
Sent: Saturday, May 05, 2007 11:33 AM
To: Tomcat Users List
Subject: Re: Connection refused when using Tomcat 6.0.10 with APR ...

Bertrand wrote:
> 
> Any ideas ? Am I missing something ? How can I debug that problem ?
>

APR on BSD was compiled with IPV6 support.
However IPV6 support on BSD (as well on Windows, because Microsoft
winsock is BSD sockets) do not support IPv4-mapped IPv6 address.

See:
http://issues.apache.org/bugzilla/show_bug.cgi?id=41973

So, the solution is to add the
address="127.0.0.1" or any other IPV4 address to the <Connector > (by
default its null and IPV6 is used)

Regards,
Mladen.

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org To unsubscribe,
e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message