tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lakshmi Venkataraman" <laks...@foundrynet.com>
Subject RE: Tomcat 5.5, IPv6, APR, HTTP and HTTPS
Date Thu, 03 May 2007 03:02:46 GMT
Corrections:
Here is a summary of what works and what does not.
Tomcat 5.5.23, WinXP, JDK 1.5, OpenSSL-0.9.8b is the base configuration.

 tcnative-1-ipv4.dll (ver 1.1.7) works for both HTTP and HTTPS.
 tcnative-1-ipv6.dll (ver 1.1.7) works for HTTP and HTTPS only with ipv6
transport
  between client and server.   It DOES NOT support ipv4 transport.

Questins 1)  Should not an ipv6 library support both ipv4 and ipv6
transport?

tcnative-1.dll (version 1.1.9) DOES not work at all for both HTTP and
HTTPS in ipv4 or ipv6 mode.

tcnative-1.dll (version 1.1.10) works for HTTP and HTTPS with ipv4
transport between client and server.

Both 1.1.9 and 1.1.0 do not have a separate ipv6 versions.

In all cases above, Tomcat 5.5 server and my application services come
up.

DOES NOT WORK means the following:
When I try to bring my web app in my browser, I see
ClassNotFoundException caused by
java.net.ConnectionException:Connection Refused in the Java Console.

Question 2) Is this a bug in tcnative-1-ipv6.dll  or am I missing
something?

Question 3) Why do versions 1.1.9 and 1.1.10 do not have a separate ipv6
library?
            Ideally you want to have the same library for both ipv4 and
ipv6.


Thanks
Lakshmi
 

-----Original Message-----
From: Lakshmi Venkataraman [mailto:lakshmi@foundrynet.com] 
Sent: Wednesday, May 02, 2007 4:57 PM
To: Tomcat Users List
Subject: Tomcat 5.5, IPv6, APR, HTTP and HTTPS

 

My setup: Tomcat 5.5.23, JDK 1.5, WIN XP I am also using tcnative-1.dll
and OpenSSL 0.9.8b Client browser: IE6, Firefox 1.5 for IPv4
IE7 for IPv6.
I successfully tested Tomcat 5.5.23 by enabling ipV6 without using APR.

SUCCESS:
If I use tcnative-ipv4.dll (version 1.1.8) I find that I am able to
start Tomcat and other service in the backend.
And my web application comes up in both HTTP and HTTPS mode.

However, if I use tcnative-ipv6.dll (version 1.1.8), Tomcat and other
backend services start successfully. 
FAILURE:  
My web application  does not come up either in HTTP or HTTPS using ipv4
or ipv6.
Java console shows ClassNotFoundException  caused by
java.net.ConnectionException:Connection Refused.

Anybody has any clue as to why I am getting the above exception for both
http://localhost and https://localhost using ipv4?
Also http://[3000::211] or https://[3000::211] does not work either in
IE 7.


I also tried tcnative-1.dll (version) 1.1.9. Same problem as
tcnative-ipv6.dll (ver 1.1.8).

I feel there is something missing in my configuration. 

Thanks in advance for your help,
Lakshmi

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message