tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lakshmi Venkataraman" <laks...@foundrynet.com>
Subject Tomcat 5.5, IPv6, APR, HTTP and HTTPS
Date Wed, 02 May 2007 23:57:11 GMT
 

My setup: Tomcat 5.5.23, JDK 1.5, WIN XP
I am also using tcnative-1.dll and OpenSSL 0.9.8b
Client browser: IE6, Firefox 1.5 for IPv4
IE7 for IPv6.
I successfully tested Tomcat 5.5.23 by enabling ipV6 without using APR.

SUCCESS:
If I use tcnative-ipv4.dll (version 1.1.8)
I find that I am able to start Tomcat and other service in the backend.
And my web application comes up in both HTTP and HTTPS mode.

However, if I use tcnative-ipv6.dll (version 1.1.8), Tomcat and other
backend
services start successfully. 
FAILURE:  
My web application  does not come up either in HTTP or HTTPS using ipv4
or ipv6.
Java console shows ClassNotFoundException
 caused by java.net.ConnectionException:Connection Refused.

Anybody has any clue as to why I am getting the above exception for 
both http://localhost and https://localhost using ipv4?
Also http://[3000::211] or https://[3000::211] does not work either in
IE 7.


I also tried tcnative-1.dll (version) 1.1.9. Same problem as
tcnative-ipv6.dll (ver 1.1.8).

I feel there is something missing in my configuration. 

Thanks in advance for your help,
Lakshmi

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message