tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manca Davide" <davide.ma...@matrix.it>
Subject RE: tomcat 6 and system property
Date Tue, 08 May 2007 08:39:48 GMT
Hello,

 

This didn't worked out, I tried to write in my server.xml to let Jfig work.

 

<Context.....>

        <Environment name="config.filename" value="/myhost/doc_root/webapps/mywebapp/WEB-INF/classes/myconfig.xml"
type="java.lang.String" override="false"/>

        <Environment name="config.location" value="file" type="java.lang.String" override="false"/>

</Context>

 

But the output was:

 

May 8, 2007 10:37:05 AM org.apache.catalina.core.StandardWrapperValve invoke

SEVERE: Allocate exception for servlet DestinationSearchServlet

org.igfay.jfig.JFigException: ConfigurationDictionary.getValueReally() ***Exception ***

Section DESTINATION not found.

        at org.igfay.jfig.JFigDictionary.getValueReally(JFigDictionary.java:292)

        at org.igfay.jfig.JFigDictionary.getValue(JFigDictionary.java:247)

        at org.igfay.jfig.JFig.getValue(JFig.java:480)

        at it.matrix.planner.DestinationSearchServlet.loadApplicationConfiguration(DestinationSearchServlet.java:501)

        at it.matrix.planner.DestinationSearchServlet.init(DestinationSearchServlet.java:162)

        at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1161)

        at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:806)

        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:133)

        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)

        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)

        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)

        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)

        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:216)

        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)

        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)

        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:767)

        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:697)

        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:889)

        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:686)

        at java.lang.Thread.run(Thread.java:595)

 

I tried also

 

<Context.....>

<Parameter name="config.filename" value="/myhost/doc_root/webapps/mywebapp/WEB-INF/classes/myconfig.xml
" type="java.lang.String" override="false"/>

        <Parameter name="config.location" value="file" type="java.lang.String" override="false"/>

</Context>

 

But it didn't work out...what do I wrong?

 

I need help please!

 

Thank you in advance

 

-----Original Message-----
From: Mikolaj Rydzewski [mailto:miki@ceti.pl] 
Sent: lunedì 7 maggio 2007 12.47
To: Tomcat Users List
Subject: Re: tomcat 6 and system property

 

Manca Davide wrote:

> I have various webapp under various hosts under one Tomcat. I'm trying

> to set system-properties for every webapps, I mean that every single

> webapp should have one or more system-property. In resin 2 or 3 it is

> possible setting them in the webapp web.xml like that:

> 

>  

> 

>   <system-property config.filename="/tmp/commenti.config.xml"/>

> 

>  

> 

>   <system-property log4j.configuration="file:////tmp/log4j.properties"/>

> 

>   <system-property config.location="file" />

> 

>  

> 

> I tried the same way in Tomcat 6 but it doesn't see system-properties.

>   

So? The <system-property /> syntax is Resin specific.

> And I cannot use the -D into the Java or Tomcat start command because of

> I have a lot of webapps under one Tomcat.

>   

I'd rather use context parameters or environment entries 

(http://tomcat.apache.org/tomcat-6.0-doc/config/context.html) than 

system properties.

 

-- 

Mikolaj Rydzewski <miki@ceti.pl>

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message