tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: [SOLVED]Tomcat native library Not found in Solaris 9
Date Sun, 13 May 2007 08:44:52 GMT
It's very likely, that it depends on the same lib in RedHat. You can 
check by using "ldd libtcnative-1.so".

The difference is: gcc is a fundamental part of the OS with Linux, so 
libgcc_s.so is ususally installed in a standard library location for 
Linux. Under Solaris it's an optional add-on installed in a separate place.

Personally I always find it anoying, that gcc put's a dependency on its 
own runtime lib into the compiled code. You could prevent it doing so, 
by changing its specs file (tehreby compiling in its convenience 
routines statically).

Regards,

Rainer

Lakshmi Venkataraman wrote:
>  
> I attached an eclipse debugger and found that an UnsatsfiedLinkError was
> thrown due to the
> Fact that libtcnative-1.so depends on libgcc_s.1.so.  
> Then I included /usr/local/lib in LD_LIBRAY_PATH.
> Tomcat's Http11AprProtocol connector starts up without any problem.
> 
> It is still not clear why on solaris 9 libtcnative-1.so depends on
> libgcc_s.1.so
> Whereas in Lunux redhat 4 it does NOT do do.
> 
> Lakshmi
> 
> -----Original Message-----
> From: Lakshmi Venkataraman [mailto:lakshmi@foundrynet.com] 
> Sent: Saturday, May 12, 2007 5:33 PM
> To: Tomcat Users List
> Subject: RE: Tomcat native library Not found in Solaris 9
> 
>  
> 
> I upgraded Tomcat to Tomcat 5.5.23 on Solaris 9. I also compiled
> APR-1.2.8, tomcat-native-1.1.8-src and openssl-0.9.8b on Solaris.
> I have placed the libtcnative-1.so in /export/home/lakshmi/Ivt55/bin.
> Ivt55 is the application directory and have INCLUDED it in
> LD_LIBRARY_PATH and PATH.
> 
> Yet Tomcat is unable to find libtcnative-1.so.  I get this message:
> 
> The Apache Tomcat Native library which allows optimal performance in
> production environments was not found on the java.library.path:
> /export/home/lakshmi/Ivt55/jre/lib/sparc/client:/export/home/lakshmi/Ivt
> 55/jre/lib/sparc:/export/home/lakshmi/Ivt55/jre/../lib/sparc:/export/hom
> e/lakshmi/Ivt55/3rdPartyPackages/Tomcat/bin:/export/home/lakshmi/Ivt55/b
> in:/export/home/lakshmi/Ivt55/database::/usr/lib
> 
> 
> I did NOT have a problem on Linux redhat 4 or Windows.
> 
> What else is missing on Solaris?
> 
> Thanks in advance for your reply,
> Lakshmi

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message