tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Smith <d...@cornell.edu>
Subject Re: Which Tomcat JARs are required?
Date Wed, 09 May 2007 15:47:32 GMT
Could you post more details?  Most Maven project only ever need the 
servlet api (and optionally jsp api) declared in dependencies as:

<dependency>
  <groupId>javax.servlet</groupId>
  <artifactId>servlet-api</artifactId>
  <version>2.4</version>
  <scope>provided</scope>
</dependency>
<dependency>
  <groupId>javax.servlet</groupId>
  <artifactId>jsp-api</artifactId>
  <version>2.0</version>
  <scope>provided</scope>
</dependency>

I can't imagine a need for tomcat specific jars in any project.

--David


lightbulb432 wrote:

>I'd like to obtain Tomcat JARs using Maven, but I don't know which of its
>JARs from the following URL are required:
>
>http://tomcat.apache.org/dev/dist/m2-repository/org/apache/tomcat/
>
>Which of those JARs are required for Tomcat?
>
>Could somebody who uses Maven with Tomcat comment on how they use it for
>obtaining Tomcat JARs?
>
>Thanks.
>  
>


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message