tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Hanik - Dev Lists <devli...@hanik.com>
Subject Re: Tomcat hprof empty file
Date Tue, 08 May 2007 12:46:03 GMT
maybe try to run it under another service manager, like the Java Service 
Wrapper
http://people.apache.org/~fhanik/wrapper.html

to rule out the case, that its a win service problem
Filip

Jason Polites wrote:
> Hi all,
>
> I am running Tomcat 5.5.23 on a Win32 platform as an NT Service, with the
> native DLL.
>
> I am experiencing the CPU spinning at 100% in our production environment,
> which is not something I have seen in our dev or staging env.  In 
> order to
> determine the problem area, I have tried running Tomcat with hprof 
> using the
> following JVM option:
>
> -Xrunhprof:cpu=samples,thread=y
>
> I am setting this in the Java options tab of the Windows service 
> dialog.  I
> get a java.hprof.txt file created in the root tomcat directory, but 
> there is
> nothing in it other than the standard intro text.
>
> This works when I run tomcat locally within eclipse (same tomcat 
> version);
> but when running in production I get no data!
>
> This is really frustrating as I can't fix the CPU problem because I can't
> identify it.
>
> Help!
>
> Thanks.
>
> ------------------------------------------------------------------------
>
> No virus found in this incoming message.
> Checked by AVG Free Edition. 
> Version: 7.5.467 / Virus Database: 269.6.2/787 - Release Date: 5/3/2007 2:11 PM
>   


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message