tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Propes, Barry L " <>
Subject RE: strange session behavior!
Date Fri, 11 May 2007 18:58:49 GMT
never mind....figured it out! I was blind where one value was not in the DB that I thought
was there..basically that's the upshot and cause for the exhausted result set problem.

-----Original Message-----
From: Johnny Kewl []
Sent: Friday, May 11, 2007 1:47 PM
To: Tomcat Users List
Subject: Re: strange session behavior!

Hi Barry.... I think you session may not have been created...
See my MOD below....

----- Original Message ----- 
From: "Propes, Barry L " <>

I'm using this code for part of my app:

String juser = request.getRemoteUser();

request.getSession(true).setAttribute("juser",juser); // make sure the 
session is created

String jusertwo = (String) request.getSession().getAttribute("juser");
out.println("Juserval is: "+juser);
out.println("Jusertwo is: "+jusertwo);

When I look at the screen (browser console), for most users I've tested, I 
see it set just fine.

For one particular user, it is breaking and looking like this:

Juserval is: TG39054 Jusert
It's odd, because it's breaking for this one user, EVEN though I've changed 
both their email address and USERid.

I have no idea what could be causing this. I did add one user with a totally 
different role than that of what had been included before, and the other 
person's ID with the new role did appear directly before this person with 
the problem. Could a hashmap in another app affect this? I wouldn't think it 
would directly. Especially if I've changed the person's userID and email 
It is so strange.

FWIW, I am using TC 4.1.31.

Let me know if any other XML attributes or other code is needed.



To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message