tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Cole <co...@woodwinds.net>
Subject Re: Tomcat and mod_jk
Date Sat, 12 May 2007 22:28:40 GMT

I had a similar problem to this in march.  I found that for me I had to
adjust the default connector information for the port 8009 in the tomcat
config file server.xml.  I made the 8009 connector look like the 8080
connector.  So I guess if you are using port 8084 for directly accessing
your tomcat you would want to make the 8009 connector look like the 8084
connector



David Short wrote:
> 
> I believe this topic, or something similar, has been covered before, so I
> apologize in advance.
> 
> I'm having an issue with Tomcat consuming 100% CPU when called from Apache
> via ajp13.  If I run my .jsp and servlet files through Tomcat directly
> (port
> 8084) all is well.  However, if Apache redirects my .jsp and servlet files
> to Tomcat via ajp13, Tomcat starts consuming CPU and after a few seconds
> consumes all 100%.
> 
> Any ideas would be greatly appreciated.
> 
> 
> Environment:
> 
> Pentium 4 (3.4 Mhz)
> 2 GB memory
> Windows XP Pro SP2
> MySQL 5.1
> Apache 2.2.4
> Mod_jk 2.2.4
> Tomcat 5.5.23
> Java 1.5.0_11-b03
> 
> 
> workers.properties
> 
> workers.tomcat_home=C:\Tomcat5
> workers.java_home=C:\Program Files\Java\jre1.5.0_11
> ps=\
> worker.list=ajp13
> worker.ajp13.port=8009
> worker.ajp13.host=localhost
> worker.ajp13.type=ajp13
> 
> 

-- 
View this message in context: http://www.nabble.com/Tomcat-and-mod_jk-tf3732833.html#a10450362
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message