tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "César Leonardo Blum Silveira" <cesa...@gmail.com>
Subject jni not working with Tomcat 5.5
Date Mon, 30 Apr 2007 19:48:19 GMT
Hello all,

I am new to using Tomcat. I have installed (on Windows XP) Apache 2.2
and Tomcat 5.5. I am using the mod_jk connector.

I have the following Tomcat-related configuration in my httpd.conf:

# Load mod_jk module
LoadModule    jk_module  modules/mod_jk.so
# Declare the module for <IfModule directive> (remove this line on Apache 2.0.x)
# AddModule     mod_jk.c
# Where to find workers.properties
JkWorkersFile conf/workers.properties
# Where to put jk shared memory
JkShmFile     logs/mod_jk.shm
# Where to put jk logs
JkLogFile     logs/mod_jk.log
# Set the jk log level [debug/error/info]
JkLogLevel    info
# Select the timestamp log format
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
# Send servlet for context /examples to worker named worker1
JkMount  /examples/servlet/* worker1
# Send JSPs  for context /examples to worker named worker1
JkMount  /examples/*.jsp worker1

And I have the following inside my workers.properties file:

worker.list=worker1
worker.worker1.type=jni
worker.worker1.host=localhost
worker.worker1.port=8009

If I set the type to ajp13, everything works fine. But with jni, I get
the following error message in logs/mod_jk.log:

[error] jk_worker.c (137): Unknown worker type jni for worker worker1

I googled it and couldn't find anything useful. Could anyone help me
on that? I *really* need it to be run in-process.

Thank you in advance,

-- 
César L. B. Silveira
http://cesarbs.wordpress.com/

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message