tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alvarez, Mike" <mike.alva...@eds.com>
Subject RE: java.net.BindException: Address already in use: JVM_Bind:8090
Date Thu, 05 Apr 2007 16:24:42 GMT
Have you verified that something other than tomcat is not using that
port?

Shut down tomcat and then telnet to that port (e.g. telnet [hostname]
[port#] Example: telnet localhost 8080) 

-----Original Message-----
From: mallika guliani [mailto:nu_age_gal@yahoo.com] 
Sent: Thursday, April 05, 2007 11:18 AM
To: tomcat-user@jakarta.apache.org
Subject: java.net.BindException: Address already in use: JVM_Bind:8090

I configured Tomcat/5.0.28 in MyEclipse 5.1 but unable to run the server
to test some examples. I changed default 8080 port in server.xml, which
was also giving same error. 
  These are the lines that I changed:
   
  <Server port="8015" shutdown="SHUTDOWN" debug="0">
  <Connector port="8090"               maxThreads="150" ...>
   
  But it keeps giving the same error:
   
  org.apache.coyote.http11.Http11Protocol init
  SEVERE: Error initializing endpoint
  java.net.BindException: Address already in use: JVM_Bind:8090
   
  SEVERE: Error starting endpoint
  java.net.BindException: Address already in use: JVM_Bind:8090
   
  StandardServer.await: create[8015]: java.net.BindException: Address
already in use: JVM_Bind
   
  All the forums say change port in Server.xml which hasn't resolved the
problem.
   
  Please advice.
   
  Thank You.

 
---------------------------------
Need Mail bonding?
Go to the Yahoo! Mail Q&A for great tips from Yahoo! Answers users.

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message